[Ironruby-core] question on RubyGems

Jay Turpin lists at ruby-forum.com
Tue Sep 23 08:42:54 EDT 2008


I did some research into getting rubygems and rake to work in IronRuby. 
The first thing I had to do was set the ENV variable GEM_PATH to the 
IronRuby/lib/ruby/gems/1.8 directory. That enabled rubygems to at least 
locate the rake gem.

But now I'm stuck on an possible issue in the rubygems library. Looks 
like it is handling the version numbers of the libraries differently 
than Ruby. I'm looking into it further.

Does anybody know how to do a --trace to print out the script callstack? 
It would certainly make it easier to track down problems in the .rb 
files.

Thanks
Jay Turpin
-- 
Posted via http://www.ruby-forum.com/.


More information about the Ironruby-core mailing list