[Ironruby-core] IronRuby Compiles Broken?

Ivan Porto Carrero ivan at flanders.co.nz
Thu Oct 23 12:49:49 EDT 2008

I got the same errors yesterday. I could build it using visual studio
Mine was on vista 32-bit in both powershell and command

On Thu, Oct 23, 2008 at 6:31 PM, Ted Milker <tmilker at gmail.com> wrote:

> Is the IronRuby tree currently broken for compiles?  I have tried
> everything I can think of to get it to build and I just get:
> Setting environment for using Microsoft Visual Studio 2008 x86 tools.
> c:\Users\ted\Desktop\IronRuby>rake compile
> (in c:/Users/ted/Desktop/IronRuby)
> Read in 17 resources from
> "c:\users\ted\desktop\ironruby\src\microsoft.scripting
> \math\MathResources.resx"
> Writing resource file...  Done.
> The command line is too long.
> rake aborted!
> Command failed with status (1): [csc
> /out:"c:\users\ted\desktop\ironruby\bu...]
> c:/Users/ted/Desktop/IronRuby/rakefile:284
> (See full trace by running task with --trace)
> c:\Users\ted\Desktop\IronRuby>
> I am running on Vista Ultimate 64bit with Visual Studio 2008
> Professional.  I have tried both the 32bit and 64bit command line
> shortcuts and I just cannot get past "The command line is too long."
> I cannot even figure out which command line is too long.  I have tried
> on two different machines(both Vista Ultimate 64bit) with the same
> results.
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20081023/27adb92a/attachment.html>

More information about the Ironruby-core mailing list