[Ironruby-core] IronRuby Compiles Broken?

Ted Milker tmilker at gmail.com
Thu Oct 23 12:31:49 EDT 2008


Is the IronRuby tree currently broken for compiles?  I have tried
everything I can think of to get it to build and I just get:

Setting environment for using Microsoft Visual Studio 2008 x86 tools.

c:\Users\ted\Desktop\IronRuby>rake compile
(in c:/Users/ted/Desktop/IronRuby)
Read in 17 resources from "c:\users\ted\desktop\ironruby\src\microsoft.scripting
\math\MathResources.resx"
Writing resource file...  Done.
The command line is too long.
rake aborted!
Command failed with status (1): [csc /out:"c:\users\ted\desktop\ironruby\bu...]
c:/Users/ted/Desktop/IronRuby/rakefile:284
(See full trace by running task with --trace)

c:\Users\ted\Desktop\IronRuby>

I am running on Vista Ultimate 64bit with Visual Studio 2008
Professional.  I have tried both the 32bit and 64bit command line
shortcuts and I just cannot get past "The command line is too long."
I cannot even figure out which command line is too long.  I have tried
on two different machines(both Vista Ultimate 64bit) with the same
results.


More information about the Ironruby-core mailing list