[Ironruby-core] Cucumber / RSpec Story Runner

Ben Hall ben2004uk at googlemail.com
Mon Oct 20 05:24:32 EDT 2008


Hi,

To get rspec to work you will need to modify the actual Ironruby
source.  I've raised bugs to get the changes required fixed, however I
did this based on 1.1.4, I think Cucumber will have a whole load more
bugs attached as it has more dependencies.

I know for a fact you won't be able to run Cucumber unmodified due to
existing bugs around gems.  (for example, gem needing .rb at the end
of the file to be able to find it)

However, I haven't had chance to take a closer look.

Ben



On Fri, Oct 17, 2008 at 2:53 PM, Curt Hagenlocher <curth at microsoft.com> wrote:
> If you explicitly set the GEM_PATH before requiring gems, you should be able to use gems that are already present.  I haven't tried any other gem operations.
>
> I assume you're running with the latest source?
>
> -----Original Message-----
> From: ironruby-core-bounces at rubyforge.org [mailto:ironruby-core-bounces at rubyforge.org] On Behalf Of Pat Gannon
> Sent: Friday, October 17, 2008 1:30 AM
> To: ironruby-core at rubyforge.org
> Subject: [Ironruby-core] Cucumber / RSpec Story Runner
>
> Has anyone tried to get Cucumber (or it's predecessor: the RSpec story
> runner) to work with IronRuby?  I have not had any luck thus far (I am
> extremely new to Ruby), and I would really like to be able to use
> Cucumber to write executable feature documentation for my .NET code.
>
> http://github.com/aslakhellesoy/cucumber/wikis
>
> I copied it under the "lib" directory, as well as several of its
> dependencies, but when I try to do "require
> 'cucumber-0.1.7/lib/cucumber'", ir (interactive ruby) fails with a stack
> overflow.  The same thing happens when I try to require some its
> dependencies manually (eg. "require 'hoe-1.8.0/lib/hoe'" and "require
> 'rake-0.8.3/lib/rake'"), but some work just fine (eg. "require
> 'polyglot-0.2.3/lib/polyglot'" and "require
> 'treetop-1.2.4/lib/treetop'").
>
> I also tried to get gem working to aide me in this process, but I had
> problems with that too.  Has anyone got gem working with IronRuby?
>
> Thanks in advance!
> Pat Gannon
> --
> Posted via http://www.ruby-forum.com/.
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>


More information about the Ironruby-core mailing list