[Ironruby-core] Problems compiling IronRuby on Mac Leopard

Ben Aurel ben.aurel at gmail.com
Tue May 6 09:23:08 EDT 2008


if I understand Seo correctly, I *have* to downgrade in order to
compile ironruby for mac. There is no other option.

Could somebody tell me the (best) way for downgrading the sources. Can
I downgrade with SVN the existing sources? If yes - how?
Or is it better to remove the checked out sources and make a checkout
again with the specific revision number? Again - how?

thanks for your help

Benh

On Tue, May 6, 2008 at 1:06 PM, Sanghyeon Seo <sanxiyn at gmail.com> wrote:
> 2008/5/6 Ben Aurel <ben.aurel at gmail.com>:
>
> >  --and than this error (?):
>  >  ./actions/comdispatch/DispCallable.cs(134,9): error CS0452: The type
>  >  `T' must be a reference type in order to use it as type parameter `T'
>  >  in the generic type or method
>  >  `Microsoft.Scripting.Actions.RuleBuilder<T>'.
>  >  ./actions/comdispatch/comtypelibdesc.cs(141,9): error CS0452: The type
>  >  `T' must be a reference type in order to use it as type parameter `T'
>  >  in the generic type or method
>  >  `Microsoft.Scripting.Actions.RuleBuilder<T>'.
>
>  This is a recent unrelated error. This problem is reported as Mono bug #387040.
>  https://bugzilla.novell.com/show_bug.cgi?id=387040
>
>  The last working revision is r98. If all you want is to try IronRuby,
>  you could update to old revisions.
>
>
>  >  When I now try to run it again I simply get:
>  >
>  >  $ sudo rake compile mono=1
>  > rake aborted!
>  >  cannot resolve path System.dll
>
>  Of course, you are using sudo, which resets the shell environment.
>  Therefore, don't.
>
>  --
>
>
> Seo Sanghyeon
>  _______________________________________________
>  Ironruby-core mailing list
>  Ironruby-core at rubyforge.org
>  http://rubyforge.org/mailman/listinfo/ironruby-core
>


More information about the Ironruby-core mailing list