[Ironruby-core] HOME env variable required

John Lam (IRONRUBY) jflam at microsoft.com
Sun Jun 29 13:22:03 EDT 2008

Thanks for the idea. I'll look for HOME first followed by USERPROFILE before failing with a better message than that :)

- John
Sent from my phone

From: Brad Wilson <dotnetguy at gmail.com>
Sent: Sunday, June 29, 2008 8:57 AM
To: ironruby-core at rubyforge.org <ironruby-core at rubyforge.org>
Subject: Re: [Ironruby-core] HOME env variable required

%HOME% is not reliably set. Some OSes will make it a combination of %HOMEDRIVE%%HOMEPATH%, but many don't (it's not set on my Vista x64 box, for example).

A much more reliable environment variable seems to be %USERPROFILE%.

On Sun, Jun 29, 2008 at 4:34 AM, Peter Bacon Darwin <bacondarwin at googlemail.com<mailto:bacondarwin at googlemail.com>> wrote:

I checked out r116 from SVN into a new clean folder.  This is what I got:

D:\dev\ruby\ironruby\head>rake compile

(in D:/dev/ruby/ironruby/head)

rake aborted!

private method `gsub' called for nil:NilClass


(See full trace by running task with --trace)

Taking a look at the rakefile,

SPEC_HOME = ENV['HOME'].gsub('\\', '/') + '/dev'

So the problem is that I don't have a HOME variable set.  Am I unusual in this respect?  Do most people have this set on their Windows machines by default?



Ironruby-core mailing list
Ironruby-core at rubyforge.org<mailto:Ironruby-core at rubyforge.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20080629/2be508d9/attachment.html>

More information about the Ironruby-core mailing list