[Ironruby-core] HOME env variable required

Brad Wilson dotnetguy at gmail.com
Sun Jun 29 11:57:32 EDT 2008


%HOME% is not reliably set. Some OSes will make it a combination of
%HOMEDRIVE%%HOMEPATH%, but many don't (it's not set on my Vista x64 box, for
example).

A much more reliable environment variable seems to be %USERPROFILE%.

On Sun, Jun 29, 2008 at 4:34 AM, Peter Bacon Darwin <
bacondarwin at googlemail.com> wrote:

>  I checked out r116 from SVN into a new clean folder.  This is what I got:
>
>
>
> D:\dev\ruby\ironruby\head>rake compile
>
> (in D:/dev/ruby/ironruby/head)
>
> rake aborted!
>
> private method `gsub' called for nil:NilClass
>
> D:/dev/ruby/ironruby/head/rakefile:15
>
> (See full trace by running task with --trace)
>
>
>
> Taking a look at the rakefile,
>
>
>
> SPEC_HOME = ENV['HOME'].gsub('\\', '/') + '/dev'
>
>
>
> So the problem is that I don't have a HOME variable set.  Am I unusual in
> this respect?  Do most people have this set on their Windows machines by
> default?
>
> Cheers,
>
> Pete
>
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>
>


-- 
http://bradwilson.typepad.com/
http://social.zune.net/member/AgilistBrad
http://www.flickr.com/photos/dotnetguy/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20080629/ea464106/attachment.html>


More information about the Ironruby-core mailing list