[Ironruby-core] YAML

oleg oleg at tkachenko.com
Thu Jun 19 18:58:55 EDT 2008

I'm currently working on improving yaml implementation. It will be better in next build.
One problem you can see in your test is that current implementation doesn't support loading symbols. That's because our implementation is a port of early version of JvYAML, which in turn was based on RbYAML, which in turn was based on PyYAML and Python doesn't have symbols.

I'm working on a fix.--


From: "Ivan Porto Carrero" <ivan at flanders.co.nz>
Sent: Thursday, June 19, 2008 10:34 AM
To: ironruby-core at rubyforge.org
Subject: [Ironruby-core] YAML 


Is yaml supposed to be working atm because when I try it, it definitely does some weird things. When I run the tests there is one test that fails the yamlorg_refcard.yml.

And this is my test.

>>> require 'yaml'
=> true
>>> $t = {:one => "one val", :two => { :nested_first => "nested val" } }
=> {:one=>"one val", :two=>{:nested_first=>"nested val"}}
>>> $y = YAML::dump $t
=> "\n--- !ruby/object:Hash\n!ruby/object:Symbol :one: !ruby/object:String one val\n!ruby/object:Symbol :two: !ruby/obje
ct:Hash\n  !ruby/object:Symbol :nested_first: !ruby/object:String nested val\n"
>>> $r = YAML::load $y
=> #<Ruby::StandardLibrary::Yaml::PrivateType:0x000005c>
>>> $r == $t
=> false
>>> $r[:one]
:0:in `Initialize': undefined local variable or method `[]' for #<Ruby::StandardLibrary::Yaml::PrivateType:0x000005c>:Ru
by::StandardLibrary::Yaml::PrivateType (NoMethodError)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20080619/433e369d/attachment.html>

More information about the Ironruby-core mailing list