[Ironruby-core] YAML

Curt Hagenlocher curth at microsoft.com
Thu Jun 19 18:37:46 EDT 2008

YAML support currently does what it needs to do in order to run Rails.  Beyond that, all bets are off ☺.

Let the flow of bug reports commence!

From: ironruby-core-bounces at rubyforge.org [mailto:ironruby-core-bounces at rubyforge.org] On Behalf Of Ivan Porto Carrero
Sent: Thursday, June 19, 2008 3:33 PM
To: ironruby-core at rubyforge.org
Subject: [Ironruby-core] YAML


Is yaml supposed to be working atm because when I try it, it definitely does some weird things. When I run the tests there is one test that fails the yamlorg_refcard.yml.

And this is my test.

>>> require 'yaml'
=> true
>>> $t = {:one => "one val", :two => { :nested_first => "nested val" } }
=> {:one=>"one val", :two=>{:nested_first=>"nested val"}}
>>> $y = YAML::dump $t
=> "\n--- !ruby/object:Hash\n!ruby/object:Symbol :one: !ruby/object:String one val\n!ruby/object:Symbol :two: !ruby/obje
ct:Hash\n  !ruby/object:Symbol :nested_first: !ruby/object:String nested val\n"
>>> $r = YAML::load $y
=> #<Ruby::StandardLibrary::Yaml::PrivateType:0x000005c>
>>> $r == $t
=> false
>>> $r[:one]
:0:in `Initialize': undefined local variable or method `[]' for #<Ruby::StandardLibrary::Yaml::PrivateType:0x000005c>:Ru
by::StandardLibrary::Yaml::PrivateType (NoMethodError)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20080619/ac0ef4ab/attachment-0001.html>

More information about the Ironruby-core mailing list