[Ironruby-core] CLR 2.0 SP1 will be the new baseline requirement to run IronRuby

John Lam (IRONRUBY) jflam at microsoft.com
Wed Jun 18 17:50:16 EDT 2008


The DLR is going to be taking a dependency on CLR 2.0 SP1 in the coming weeks: http://support.microsoft.com/kb/945757. CLR 2.0 SP1 (version 2.0.50727.1433) shipped back in November of 2007, and is available as a standalone download, and is included with .Net Framework 3.5. It includes a number of important bug fixes in it that let us take out some workarounds in our codebase. We'll be putting in runtime checks in our codebase to guard against running in CLR 2.0, since this will cause code to blow up at runtime inside of our dynamic sites.

We are also going to be transitioning to C# 3.0 syntax in our sources as well, although there won't be a dependency taken on System.Core, which means that CLR 2.0 SP1 is all that users will need to have installed to run IronRuby.

Please let us know if you foresee problems with these changes.

Thanks,
-John

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20080618/aa66678a/attachment.html>


More information about the Ironruby-core mailing list