[Ironruby-core] Having difficulties using custom C# dlls with namespaces within IronRuby code

Tomas Matousek Tomas.Matousek at microsoft.com
Thu Jun 12 12:31:49 EDT 2008


The casing is not right.

include mywebsvcproxyns

is the same as

include(mywebsvcproxyns())

I.e. mywebsvcproxyns is a method call.

You need to start namespaces with a capital letter. BTW, that's also .NET naming convention.

Tomas

From: ironruby-core-bounces at rubyforge.org [mailto:ironruby-core-bounces at rubyforge.org] On Behalf Of Philippe Monnet
Sent: Thursday, June 12, 2008 5:37 AM
To: IronRuby
Subject: [Ironruby-core] Having difficulties using custom C# dlls with namespaces within IronRuby code

Now that the Beta 2 of Silverlight provides support for WSI web services, I can now get an all-C# Silverlight app to call Rails (Action Web Service) web services.
So I encapsulated my generated web service proxy in its own DLL so I can use it from Ruby, like so:

...
require "System.ServiceModel"
require "mywebsvcproxy" #my DLL
...
include System::ServiceModel
include mywebsvcproxyns
...
svcproxy = mywebsvcproxyns::MyRoRServiceReference::MyRorWsPortClient.new()
... etc ...

However I keep getting an error as soon as I hit the include for my assembly namespace.
I have tried to simplify the issue by creating a very tiny assembly with a C# class with 2 properties and a constructor but I get the same issue.
I even tried that from IR with the same results:
  - the require "mywebsvcproxy" returns true
  - if I evaluate mywebsvcproxyns I get undefined
The DLL is in the same location as other .rb files in my Silverlight app directory. I have even tried to provide an absolute path in the require statement but that did not make any difference.
After putting this email on hold for another check, I found out that as soon as I remove the namespace inside my custom assembly everything works like a charm. I ended up also removing all namespace references in the C# generated proxy and was able to get my IronRuby Silverlight app to successfully invoke my Rails web service.

But coming back to the namespace issue, am I missing something basic in how I should be integrating with custom assemblies?
Or is this a limitation for the time being?

Philippe
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20080612/38d6773a/attachment.html>


More information about the Ironruby-core mailing list