[Ironruby-core] can't require any of the libs

Curt Hagenlocher curth at microsoft.com
Wed Jun 11 20:05:13 EDT 2008

We don’t do anything auto-magic as far as the path is concerned.  I specify the include directories on the command-line by running the now-notorious “ir.cmd”.  My version of the file looks like this:

%MERLIN_ROOT%\bin\debug\ir.exe -I %MERLIN_ROOT%\..\External\Languages\Ruby\ruby-1.8.6\lib\ruby\1.8;%MERLIN_ROOT%\..\External\Languages\Ruby\ruby-1.8.6\lib\ruby\site_ruby\1.8;%MERLIN_ROOT%\Languages\Ruby\Libs %*

You’d obviously need to change the paths to suit your file system layout.

From: ironruby-core-bounces at rubyforge.org [mailto:ironruby-core-bounces at rubyforge.org] On Behalf Of Ivan Porto Carrero
Sent: Wednesday, June 11, 2008 5:00 PM
To: ironruby-core at rubyforge.org
Subject: [Ironruby-core] can't require any of the libs


I tried requiring any of the libs that are included in the ironruby source.

I tried putting the libs folder in different places but to no avail.
So far i've put the libs in.


where do I have to copy the libs folder to so that IronRuby picks it up?
I can require them when i put them in the same folder where I call the ir command.

+ C:\tools\IronRuby\build\debug
» ir
IronRuby<> on .NET 2.0.50727.1434
Copyright (c) Microsoft Corporation. All rights reserved.

Note that local variables do not work today in the console.
As a workaround, use globals instead (eg $x = 42 instead of x = 42).

>>> require 'yaml'
=> true

Somehow this doesn't seem right to me.. but that's probably because I'm putting my stuff in the wrong place.

also when I compile with rake compile config=release
it will just compile a debug version
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20080611/13573613/attachment.html>

More information about the Ironruby-core mailing list