[Ironruby-core] can't require any of the libs

Ivan Porto Carrero ivan at flanders.co.nz
Wed Jun 11 19:59:57 EDT 2008


I tried requiring any of the libs that are included in the ironruby source.

I tried putting the libs folder in different places but to no avail.
So far i've put the libs in.


where do I have to copy the libs folder to so that IronRuby picks it up?
I can require them when i put them in the same folder where I call the ir

+ C:\tools\IronRuby\build\debug
» ir
IronRuby on .NET 2.0.50727.1434
Copyright (c) Microsoft Corporation. All rights reserved.

Note that local variables do not work today in the console.
As a workaround, use globals instead (eg $x = 42 instead of x = 42).

>>> require 'yaml'
=> true

Somehow this doesn't seem right to me.. but that's probably because I'm
putting my stuff in the wrong place.

also when I compile with rake compile config=release
it will just compile a debug version
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20080612/39a01cca/attachment.html>

More information about the Ironruby-core mailing list