[Ironruby-core] Trying to duplicate Phil Haack's example

Peter Bacon Darwin bacondarwin at googlemail.com
Mon Jun 9 01:57:28 EDT 2008


Hi Greg,
I think you would be better off using the version of rspec included with
IronRuby at the moment rather than the one you downloaded from RSpec.

My results yesterday were from requiring the spec_helper.rb contained within
the trunk\tests\ironruby\specs folder.

I tried downloading RSpec 1.1.4, requiring spec_helper.rb in there and I get
the same error as you.

Pete


-----Original Message-----
From: ironruby-core-bounces at rubyforge.org
[mailto:ironruby-core-bounces at rubyforge.org] On Behalf Of Greg Akins
Sent: Sunday,08 June 08, 2008 22:47
To: ironruby-core at rubyforge.org
Subject: Re: [Ironruby-core] Trying to duplicate Phil Haack's example

Ignoring the MVC requires, and just trying to require rspec, I get

c:\Libraries\IronRuby\trunk\src\IronRuby.Libraries\Builtins\kernelops.cs:300
:in
`require': no such file to load -- stringio (LoadError)
        from :0:in `Initialize##3'
        from
c:\Libraries\IronRuby\trunk\src\IronRuby.Libraries\Builtins\kernelo
ps.cs:300:in `require'
        from :0:in `Initialize##1'

Seems like the paths are correct, so I'm not sure why I'm getting this...

On Sun, Jun 8, 2008 at 5:36 PM, Greg Akins <angrygreg at gmail.com> wrote:
> When I used the output from rake compile, I didn't those errors.
>
> My attempt at duplicating Phil's blog still didn't work, but I haven't
> tried all of Peter's suggestions yet.
>
> --
> Greg Akins
>
> http://www.pghcodingdojo.org
> http://www.insomnia-consulting.org/monologue
>



-- 
Greg Akins

http://www.pghcodingdojo.org
http://www.insomnia-consulting.org/monologue
_______________________________________________
Ironruby-core mailing list
Ironruby-core at rubyforge.org
http://rubyforge.org/mailman/listinfo/ironruby-core



More information about the Ironruby-core mailing list