[Ironruby-core] Trying to duplicate Phil Haack's example

Jim Deville jdeville at microsoft.com
Sun Jun 8 21:27:38 EDT 2008

For the record the Rakefile is fixed on the internal side, but I didn't want to venture screwing up either repository by trying a push without John being around. When I get into the office, I'll ask John to make sure I don't screw stuff up and I'll push out a changeset that will include the new Rakefile (compiling to ir.exe) and a svn version of ir.cmd and irvars.bat.


From: ironruby-core-bounces at rubyforge.org [ironruby-core-bounces at rubyforge.org] On Behalf Of Peter Bacon Darwin [bacondarwin at googlemail.com]
Sent: Sunday, June 08, 2008 2:04 PM
To: gakins at insomnia-consulting.org; ironruby-core at rubyforge.org
Subject: Re: [Ironruby-core] Trying to duplicate Phil Haack's example

This is definitely a problem with the SIGNED conditional compilation symbol.
I can reproduce it by checking out a clean copy of r113 and building via
Visual Studio 2008.

At least two of the project files in the solution have the SIGNED symbol set
in their Debug configuration.  Some projects have an ExternalDebug
configuration which is supposed not to have this set but the whole lot
appears to be in a bit of a mess at the moment.

The thing to do is go through each project and remove any traces of SIGNED.

If you build this revision with rake compile you don't get the SIGNED
problem because the rake task does not use the .csproj files to build the
assemblies.  What you do get in that case, though, is a corrupt ir.cmd file.
The output from rake compile is ir.cmd instead of ir.exe.  Just rename the
file to ir.exe and all is well.

Finally, I did have some problems requiring the MVC assemblies.  I
downloaded the most recent ones (Preview 3) but the System.Web.Abstractions
and System.Web.Routing had for their version number.  I couldn't get
IronRuby to require them from the GAC.

What I found was that if you move them into the local folder and require
them without their full name then all works fine.  Here is my mvc.rb script
and output (note my mvc.rb file is in trunk\tests\ironruby\specs\) ...

require File.dirname(__FILE__) + '/spec_helper'
require 'System.Web.Routing'
require 'System.Web.Mvc'
require 'System.Web.Abstractions'

describe "Route#<<" do

  it "can create RouteCollection which is empty" do
    rc = System::Web::Routing::RouteCollection.new
    rc.count.should == 0

  it "can add route to RouteCollection" do
    rc = System::Web::Routing::RouteCollection.new
    r = System::Web::Routing::Route.new "", nil
    rc.add "route-name", r

    rc.count.should == 1



D:\dev\ruby\ironruby\mvc\tests\ironruby\Specs>..\..\..\build\debug\ir mvc.rb

- can create RouteCollection which is empty
- can add route to RouteCollection

2 examples, 0 failures

Hope that helps.

-----Original Message-----
From: ironruby-core-bounces at rubyforge.org
[mailto:ironruby-core-bounces at rubyforge.org] On Behalf Of Greg Akins
Sent: Sunday,08 June 08, 2008 17:39
To: ironruby-core at rubyforge.org
Subject: [Ironruby-core] Trying to duplicate Phil Haack's example

Using rev 113, I tried to duplicate Phil Haack's blog post (here

I downloaded Rspec 1.1.4

and ran the exact code from the blog; setting the path on the first
'require' to point to where I extracted RSpect

require File.dirname(__FILE__) +

The error I get is:

IronRuby.Libraries:0:in `require': Type 'IronRuby, Version=,
ral, PublicKeyToken=31bf3856ad364e35, Ruby.Runtime.RubyContext' is missing
or ca
nnot be loaded. (Microsoft::Scripting::Runtime::MissingTypeException)
        from :0:in `Initialize##1'

When I comment out the entire file, and just include the first
'require' I still get this error; so I assume the problem is in
loading that RSpect spec_helper file?

Anyone else run into this?

Greg Akins

Ironruby-core mailing list
Ironruby-core at rubyforge.org

Ironruby-core mailing list
Ironruby-core at rubyforge.org

More information about the Ironruby-core mailing list