[Ironruby-core] Trying to duplicate Phil Haack's example

Peter Bacon Darwin bacondarwin at googlemail.com
Sun Jun 8 13:58:53 EDT 2008


Is this not the old SIGNED problem?
Pete

-----Original Message-----
From: ironruby-core-bounces at rubyforge.org
[mailto:ironruby-core-bounces at rubyforge.org] On Behalf Of Greg Akins
Sent: Sunday,08 June 08, 2008 17:39
To: ironruby-core at rubyforge.org
Subject: [Ironruby-core] Trying to duplicate Phil Haack's example

Using rev 113, I tried to duplicate Phil Haack's blog post (here
http://haacked.com/archive/2008/04/09/my-first-ironruby-unit-test-spec-for-a
sp.net-mvc.aspx)

I downloaded Rspec 1.1.4

and ran the exact code from the blog; setting the path on the first
'require' to point to where I extracted RSpect

require File.dirname(__FILE__) +
'/../../Libraries/rspec-1.1.4/spec/spec_helper'

The error I get is:

IronRuby.Libraries:0:in `require': Type 'IronRuby, Version=1.0.0.0,
Culture=neut
ral, PublicKeyToken=31bf3856ad364e35, Ruby.Runtime.RubyContext' is missing
or ca
nnot be loaded. (Microsoft::Scripting::Runtime::MissingTypeException)
        from :0:in `Initialize##1'

When I comment out the entire file, and just include the first
'require' I still get this error; so I assume the problem is in
loading that RSpect spec_helper file?

Anyone else run into this?

-- 
Greg Akins

http://www.pghcodingdojo.org
http://www.insomnia-consulting.org/monologue
_______________________________________________
Ironruby-core mailing list
Ironruby-core at rubyforge.org
http://rubyforge.org/mailman/listinfo/ironruby-core



More information about the Ironruby-core mailing list