[Ironruby-core] Running rake mspec:lib

John Lam (IRONRUBY) jflam at microsoft.com
Thu Jun 5 12:27:54 EDT 2008

Can you verify this behavior by doing a local deploy and running the svn build from a non merlin cmd prompt?

- John
Sent from my phone

From: Jim Deville <jdeville at microsoft.com>
Sent: Thursday, June 05, 2008 12:24 PM
To: ironruby-core at rubyforge.org <ironruby-core at rubyforge.org>
Subject: Re: [Ironruby-core] Running rake mspec:lib

Optparse should be in the Libs folder with our hacks and such. If it’s not then something didn’t get pushed out correctly.


From: ironruby-core-bounces at rubyforge.org [mailto:ironruby-core-bounces at rubyforge.org] On Behalf Of Michael Letterle
Sent: Thursday, June 05, 2008 6:28 AM
To: ironruby-core at rubyforge.org
Subject: Re: [Ironruby-core] Running rake mspec:lib

Copy optparse.rb from an MRI installation (i.e. lib/ruby/1.8/optparse.rb) into the same directory as ir.exe .. I believe this worked for me when I was working on getting mspec running.
On Thu, Jun 5, 2008 at 8:50 AM, Peter Bacon Darwin <bacondarwin at googlemail.com<mailto:bacondarwin at googlemail.com>> wrote:

I am having trouble running the RubySpecs from rake.

First I get this:

D:\dev\ruby\ironruby\head>rake mspec:lib

(in D:/dev/ruby/ironruby/head)

mspec/bin/mspec:141:in `exec': No such file or directory - d:\dev\ruby\ironruby\head\build\release\ir.cmd (Errno::ENOENT)

        from mspec/bin/mspec:141:in `run'

        from d:/dev/ruby/ironruby/head/tests/ironruby/util/mspec/lib/mspec/utils/script.rb:91:in `main'

        from mspec/bin/mspec:146

rake aborted!

Command failed with status (1): [ruby mspec/bin/mspec ci -t d:\dev\ruby\iro...]

D:/dev/ruby/ironruby/head/rakefile:350:in `invoke_mspec'

(See full trace by running task with --trace)

It appears that ir.cmd is hard-coded inside rake to look in the release folder rather than debug, which is to where rake compile is building.

OK so I copy the files over from debug to release and now I get:

D:\dev\ruby\ironruby\head>rake mspec:lib

(in D:/dev/ruby/ironruby/head)

d:\dev\ruby\ironruby\head\src\IronRuby.Libraries\Builtins\kernelops.cs:300:in `require': no such file to load -- optparse (LoadError)

        from :0:in `Initialize##1'

rake aborted!

Command failed with status (1): [ruby mspec/bin/mspec ci -t d:\dev\ruby\iro...]

D:/dev/ruby/ironruby/head/rakefile:351:in `invoke_mspec'

(See full trace by running task with --trace)

I get the same result with rake mspec:core and mspec:lang.

Any ideas?


Ironruby-core mailing list
Ironruby-core at rubyforge.org<mailto:Ironruby-core at rubyforge.org>

Michael Letterle
[Polymath Prokrammer]
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20080605/ec11fafb/attachment.html>

More information about the Ironruby-core mailing list