[Ironruby-core] rake mspec:... broken in r127

John Lam (IRONRUBY) jflam at microsoft.com
Sun Jul 27 14:36:18 EDT 2008


Thanks for the bug report. Let me investigate - likely will be tomorrow since I am catching up on family stuff after 2 weeks on the road.

Thanks,
-John

From: ironruby-core-bounces at rubyforge.org [mailto:ironruby-core-bounces at rubyforge.org] On Behalf Of Peter Bacon Darwin
Sent: Sunday, July 27, 2008 10:58 AM
To: ironruby-core at rubyforge.org
Subject: Re: [Ironruby-core] rake mspec:... broken in r127

Further to this.  The problem seems to have been introduced between r121 and r122.
Pete

From: Peter Bacon Darwin [mailto:bacondarwin at googlemail.com]
Sent: Sunday,27 July 27, 2008 15:48
To: 'ironruby-core at rubyforge.org'
Subject: rake mspec:... broken in r127

After shifting up to 127 I can't get run the rubyspecs any more.
I fixed up the .irconfig.rb and default.mspec files correctly (by the way I had to explicitly specify the MRI binary file in .irconfig.rb since it didn't seem to be able to find it any more).
I have also pulled the latest mspec, rubyspec and ironruby-tags from jflam's GitHub account.  (I also tried pulling in Jim Deville's versions too).

Now when I run a rubyspec I get:

D:\dev\ruby\ironruby\r127>rake mspec:core Fixnum
(in D:/dev/ruby/ironruby/r127)
d:\dev\ruby\ironruby\r127\src\microsoft.scripting.core\actions\callsite.cs:288:in `UpdateAndExecute': No such file or directory - No such file or directory - d:/dev/ruby/ironruby/r127/tests/ironruby/u
til/and (Errno::ENOENT)
        from d:\dev\ruby\ironruby\r127\src\microsoft.scripting.core\actions\updatedelegates.generated.cs:34:in `Update2'
        from d:\dev\ruby\ironruby\r127\src\microsoft.scripting.core\runtime\ScriptCode.cs:79:in `Run'
        from d:\dev\ruby\ironruby\r127\src\microsoft.scripting.core\sourceunit.cs:246:in `ExecuteProgram'
rake aborted!
Command failed with status (1): [d:/ruby/bin/ruby.exe d:/dev/ruby/ironruby/...]
D:/dev/ruby/ironruby/r127/rakefile:409:in `invoke_mspec'
(See full trace by running task with --trace)

I guess there is something inside Rakefile or nearby that is breaking this?  Unfortunately I can't get onto the SVN repository to search the log history to see what changed (Bring on Git, I say).

Any ideas?
Cheers
Pete
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20080727/0e6df949/attachment.html>


More information about the Ironruby-core mailing list