[Ironruby-core] Littl' question about the build process

John Messerly jomes at microsoft.com
Wed Jan 16 14:39:39 EST 2008

John Lam (DLR):

> Tomas Restrepo:
> > Personally, I'm building with VS2008 for now, and wouldn't mind being
> > forced to use VS2008 to develop. The more interesting question is
> > whether .NET 3.5 would become the minimum requirement for the DLR and
> > IronRuby *at runtime*. If the idea is to still be targeting plain
> .NET
> > 2.0 for runtime, I think that would be a lot better and more
> palatable
> > for many people.
> We're targeting CLR v2.0 which is the version of the CLR that ships in
> .NET 3.5 (confusing, yes :)).
> C# 3.0 doesn't require new features from the CLR, just some new
> libraries (System.Core and friends).

Don't you still need to install the .NET 3.5 runtime though, if we start using System.Core features?
I think if we just use compiler features (like "var" & the new closure syntax), we can still target .NET 2.0 runtime.

- John

More information about the Ironruby-core mailing list