[Ironruby-core] Littl' question about the build process

Robert Bazinet rbazinet at gmail.com
Wed Jan 16 10:07:37 EST 2008


Has the goal of IronRuby to require .NET 3.5 all this time?  If so, I guess
I missed it but it makes sense and makes the technology better.

-Rob

On Jan 16, 2008 10:04 AM, John Lam (DLR) <jflam at microsoft.com> wrote:

> Jb Evain:
>
> > That's probably the best way to reach and ease most people. I tend to
> > simply suffix the filename with the VS version it targets, ex:
> > IronRuby-2008.csproj.
> > Along with a script to update the csprojs to keep them in sync :)
>
> It's not VS that we're concerned about, it's C#. It would be so nice to be
> able to type:
>
> var greaterThanSharedSite = DynamicSite<object, object,
> object>.Create(InstanceCallAction(">", ArgumentKind.Simple));
>
> DynamicSite<object, object, object> greaterThanSharedSite =
> DynamicSite<object, object, object>.Create(InstanceCallAction(">",
> ArgumentKind.Simple));
>
> But we can't move to the new compiler until we get enough folks agreeing
> to switch over ...
>
> -John
>
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>



-- 
Rob Bazinet
http://www.accidentaltechnologist.com
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/ironruby-core/attachments/20080116/39a37368/attachment.html 


More information about the Ironruby-core mailing list