[Ironruby-core] problems with gems

Ivan Porto Carrero ivan at flanders.co.nz
Wed Dec 31 06:42:44 EST 2008


Hi

I tried to install the rails gem using igem. Is that supposed to work?

» igem install rails
ERROR:  Error installing rails:
        attempt to install file into
"test/fixtures/test_mailer/implicitly_multipart_example.text.html.erb~"
under
ools/ironruby/merlin/External/languages/ruby/ruby-1.8.6/lib/ironruby/gems/1.8/gems/actionmailer-2.2.2"

I then tried to install them one by one with --ignore-dependencies

» igem install --ignore-dependencies --verbose activesupport-2.2.2.gem
Installing gem actionmailer-2.2.2
Using local gem
C:/tools/ironruby/merlin/main/Languages/Ruby/libs/../../../../External/languages/ruby/ruby-1.8.6//
onruby/gems/1.8/cache/actionmailer-2.2.2.gem
ERROR:  While executing gem ... (NoMethodError)
    undefined method `include?' for nil:NilClass

When I copied the gem files, cache and specifications over from MRI they
list properly but when I try to generate an application skeleton it seems
like something is wrong in the way it handles the paths.

» irails test_irails
c:\tools\ironruby\merlin\main\Languages\Ruby\Libraries.LCA_RESTRICTED\Builtins\KernelOps.cs:390:in
`require': no such fi
le to load --
C:/tools/ironruby/merlin/External/languages/ruby/ruby-1.8.6/lib/ironruby/gems/1.8/gems/-2.2.2/bin/../lib/r
uby_version_check (LoadError)
        from custom_require.rb:26:in `require'
        from :0
        from
c:\tools\ironruby\merlin\main\Languages\Ruby\Libraries.LCA_RESTRICTED\Builtins\KernelOps.cs:374:in
`load'
        from :0

I had a similar thing happen to me when I tried to install rake but then it
created a folder -0.8.3 instead of rake-0.8.3 after some tinkering i did get
rake working but rails doesn't seem to be really happy atm.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20081231/7caaeec9/attachment.html>


More information about the Ironruby-core mailing list