[Ironruby-core] Need help building IronRuby on Mono 2 + OS X

C. K. Ponnappa ckponnappa at gmail.com
Mon Dec 29 23:46:14 EST 2008


Hey guys,

I'm running on OS X 10.5.5 with Mono 2.0 (installed via Ports). I ran

rake compile mono=1

I do have pathname2 installed and am using IronRuby trunk revision 180.

I get the following error:
~/Work/ruby/ironruby$ rake compile mono=1  --trace
(in /Users/schonira/Work/ruby/ironruby)
rake aborted!
no such file to load -- /Users/schonira/Work/ruby/ironruby/rake\test.rake
/Library/Ruby/Gems/1.8/gems/rake-0.8.3/lib/rake.rb:1598:in `load'
/Library/Ruby/Gems/1.8/gems/rake-0.8.3/lib/rake.rb:1598:in `load'
/Library/Ruby/Gems/1.8/gems/rake-0.8.3/lib/rake.rb:2413:in `load_imports'
/Library/Ruby/Gems/1.8/gems/rake-0.8.3/lib/rake.rb:2356:in 
`raw_load_rakefile'
/Library/Ruby/Gems/1.8/gems/rake-0.8.3/lib/rake.rb:1985:in `load_rakefile'
/Library/Ruby/Gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in 
`standard_exception_handling'
/Library/Ruby/Gems/1.8/gems/rake-0.8.3/lib/rake.rb:1984:in `load_rakefile'
/Library/Ruby/Gems/1.8/gems/rake-0.8.3/lib/rake.rb:1969:in `run'
/Library/Ruby/Gems/1.8/gems/rake-0.8.3/lib/rake.rb:2036:in 
`standard_exception_handling'
/Library/Ruby/Gems/1.8/gems/rake-0.8.3/lib/rake.rb:1967:in `run'
/Library/Ruby/Gems/1.8/gems/rake-0.8.3/bin/rake:31
/usr/bin/rake:19:in `load'
/usr/bin/rake:19

Can someone help me out please?

Thanks!
Sidu.
http://blog.sidu.in


More information about the Ironruby-core mailing list