[Ironruby-core] Can't build under Mono

Jim Deville jdeville at microsoft.com
Tue Aug 5 20:21:31 EDT 2008


Yes you did, and I'm trying to get it in. John asked me to work on it during the rush upto the OSCON talk. Between that and a family emergency, I haven't had much of a chance to work on it. I'll try to get to it this week.


JD

> -----Original Message-----
> From: ironruby-core-bounces at rubyforge.org [mailto:ironruby-core-
> bounces at rubyforge.org] On Behalf Of Sanghyeon Seo
> Sent: Tuesday, August 05, 2008 5:17 PM
> To: ironruby-core at rubyforge.org
> Subject: Re: [Ironruby-core] Can't build under Mono
>
> 2008/8/6 Jim Deville <jdeville at microsoft.com>:
> > It means that there is more than one ruby/ruby.exe on your path,
> which you
> > probably figured out. The workaround is to copy default.irconfig.rb
> to
> > ~/.irconfig.rb, then edit the file to make the MRI variable point to
> the
> > right path.
>
> Actually, what happens is that on Mac OS X Ruby binary is called
> "ruby", but current build script only checks for "ruby.exe", and if
> "number of ruby found != 1" then it says "more than one ruby found",
> which is false since it's less than one in this case.
>
> I believe I sent a fix for this more than a month ago?!
> http://sparcs.kaist.ac.kr/~tinuviel/download/IronRuby/patch-find-
> executable
>
> --
> Seo Sanghyeon
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core



More information about the Ironruby-core mailing list