[Ironruby-core] Can't build under Mono

Jim Deville jdeville at microsoft.com
Tue Aug 5 19:47:09 EDT 2008

It means that there is more than one ruby/ruby.exe on your path, which you probably figured out. The workaround is to copy default.irconfig.rb to ~/.irconfig.rb, then edit the file to make the MRI variable point to the right path.


From: ironruby-core-bounces at rubyforge.org [mailto:ironruby-core-bounces at rubyforge.org] On Behalf Of Joe Fiorini
Sent: Tuesday, August 05, 2008 4:23 PM
To: ironruby-core at rubyforge.org
Subject: Re: [Ironruby-core] Can't build under Mono

I'm on svn r126
On Tue, Aug 5, 2008 at 7:08 PM, Joe Fiorini <joe at faithfulgeek.org<mailto:joe at faithfulgeek.org>> wrote:
Trying to build under Mono 1.9 on Mac OSX 10.5.4, I'm getting the error:

Found more than one version of ruby.exe on your path

when running "rake compile mono=1"

Any thoughts on what might be happening?  Any other details I can provide?


joe fiorini
// freelancing & knowledge sharing

joe fiorini
// freelancing & knowledge sharing
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20080805/173ce3ca/attachment.html>

More information about the Ironruby-core mailing list