[Ironruby-core] rbx.exe hits 3GB memory usage during "rake test"

Aaron Junod tranqy at gmail.com
Sat Apr 26 15:41:29 EDT 2008

I just ran rake test and didn't get the same result. rbx never took more
then 50 megs of ram, but the process ended with the error below after
running for a few minutes. I'm on the same version of Ruby as you, but
running 32 bit Windows 2k3 Standard. What version is your pathname2 gem (I
think that's the only gem that's required, and I know there are version
problems there). I'm on 1.5.2. Did you try rake spec as well?

:0:in `do_generate': undefined local variable or method `methods' for
t (NoMethodError)
        from :0:in `#block162'
c:\IronRuby\src\IronRuby.Libraries\Extensions\IListOps.cs:785:in `E
        from :0:in `Initialize##1'rake aborted!
Command failed with status (1): ["c:\ironruby\build\debug\rbx.exe"
(See full trace by running task with --trace)


On Sat, Apr 26, 2008 at 2:34 PM, Paul Batum <paul.batum at gmail.com> wrote:

> Hi there,
> Today I decided to take a look at IronRuby. I pulled the source down as
> demonstrated in the video, followed the build instructions on the wiki, and
> then ran the unit tests using the command 'rake test'. After letting it
> execute for a minute or two, I noticed no new results were appearing, my
> system was no longer responding properly and the rbx.exe process was using
> approximately 3GB of memory. I killed it, and this is is what was in the
> console buffer:
> repro: (a,b),c = *[nil]
> nil; nil; nil;
> repro: (a,b),c = *[1]
> 1; nil; nil;
> repro: (a,b),c = *[1,2]
> 1; nil; 2;
> repro: (a,b),c = 1,*[2,3]
> 1; nil; 2;
> repro: (a,b),c = *[[]]
> nil; nil; nil;
> repro: (a,b),c = 1,*[]
> 1; nil; nil;
> repro: (a,b),c = [1,2],3
> 1; 2; 3;
> repro: (a,b),c = nil,1
> nil; nil; 1;
> rake aborted!
> I'm running 64-bit Vista. I did a 'gem update' before building the source.
> ruby -v gives me:
> ruby 1.8.6 (2007-09-24 patchlevel 111) [i386-mswin32]
> After it happened the first time, I deleted my entire local copy of the
> source, pulled it all down again and then got the exact same result.
> I was wondering whether anyone has come across this before or has any
> suggestions. Cheers!
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/ironruby-core/attachments/20080426/d4402e29/attachment.html>

More information about the Ironruby-core mailing list