[Ironruby-core] AG_E_PARSER_BAD_TYPE when using Grid

Jimmy Schementi Jimmy.Schementi at microsoft.com
Wed Apr 9 22:17:35 EDT 2008


Great! In general, make sure that the x:Class of your XAML matches the type of the first argument you pass into load_root_visual.

~js

> -----Original Message-----
> From: ironruby-core-bounces at rubyforge.org [mailto:ironruby-core-
> bounces at rubyforge.org] On Behalf Of Thibaut Barrère
> Sent: Wednesday, April 09, 2008 7:05 PM
> To: ironruby-core at rubyforge.org
> Subject: Re: [Ironruby-core] AG_E_PARSER_BAD_TYPE when using Grid
>
> Hi,
>
> the root element had x:Class set incorrectly to
> x:Class="GridSample.Page".
>
> Chaning it to "System.Windows.Controls.Grid" solved the issue.
>
> thanks!
>
> -- Thibaut
>
> 2008/4/10, Jimmy Schementi <Jimmy.Schementi at microsoft.com>:
> >
> >
> >
> >
> > Are you using the Blend 2 Preview for Silverlight? If not, grab it
> from Silverlight.net.
> >
> >
> >
> > If you are, then can you send me what your XAML looks like? I suspect
> that the root element of your XAML has x:Class set incorrectly for
> Ruby. If Grid is your root ...
> >
> >
> >
> > app.xaml
> >
> > <Grid x:Class="System.Windows.Controls.Grid" ...>
> >
> > </Grid>
> >
> >
> >
> > app.rb
> >
> > System::Windows::Application.current.load_root_visual Grid.new,
> "app.xaml"
> >
> >
> >
> > ~js
> >
> >
> >
> >
> >
> >
> > From: ironruby-core-bounces at rubyforge.org [mailto:ironruby-core-
> bounces at rubyforge.org] On Behalf Of Ivan Porto Carrero
> >  Sent: Wednesday, April 09, 2008 3:18 PM
> >  To: ironruby-core at rubyforge.org
> >  Subject: Re: [Ironruby-core] AG_E_PARSER_BAD_TYPE when using Grid
> >
> >
> >
> >
> > You need to change the namespace of the xaml file probably.
> >  Expression blend generates xaml for WPF not Silverlight.
> >
> >
> >  I used the grid control in my digg client.. so i guess it works fine
> :)
> >
> >
> > On Thu, Apr 10, 2008 at 10:11 AM, Thibaut Barrère
> <thibaut.barrere at gmail.com> wrote:
> >
> > Hi again,
> >
> >  I get a XamlException with error AG_E_PARSER_BAD_TYPE whenever I use
> a Grid control inside the Xaml (even with an Expression Blend generated
> Xaml file).
> >
> >  Is the Grid control currently supported when working with IronRuby ?
> >
> >  -- Thibaut
> >  _______________________________________________
> >  Ironruby-core mailing list
> >  Ironruby-core at rubyforge.org
> >  http://rubyforge.org/mailman/listinfo/ironruby-core
> >
> >
> > _______________________________________________
> >  Ironruby-core mailing list
> >  Ironruby-core at rubyforge.org
> >  http://rubyforge.org/mailman/listinfo/ironruby-core
> >
> >
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core


More information about the Ironruby-core mailing list