[Ironruby-core] Cannot debug IronRuby + Silverlight - any hint ?

Jimmy Schementi Jimmy.Schementi at microsoft.com
Wed Apr 9 22:16:32 EDT 2008


Woops, it's suppose to be a comma, my fault.

I may be mistaken, but I believe only the IronRuby bits on http://dynamicsilverlight.net can be debugged in Silverlight. I just did a test and I cannot debug the ruby clock demo with the Silverlight SDK bits, but it works with the Dynamic Silverlight bits. So, first make sure you're using the latest and greatest stuff from the web.

If you run the app, open the ruby file in VS, put a breakpoint in it, attach to your browser running the app, and refresh the browser, you should see the breakpoint flicker a bit and then break at the line.

This shouldn't depend on any IE settings; you can debug Firefox as well.

From: ironruby-core-bounces at rubyforge.org [mailto:ironruby-core-bounces at rubyforge.org] On Behalf Of Thibaut Barrère
Sent: Wednesday, April 09, 2008 6:43 PM
To: ironruby-core at rubyforge.org
Subject: Re: [Ironruby-core] Cannot debug IronRuby + Silverlight - any hint ?

Hi Jimmy,

thanks for you answer. The application cannot seem to start when using a semicolon to separate values in initParams. I tried comma instead (the application manages to start this way - not sure if the param is passed properly though):

      <param name="initParams" value="debug=true,reportErrors=errorLocation" />

either way, the breakpoints remain in the same state (inactivated).

I guess it's a first step although something still must be missing. When refreshing the browser windows, should a new debugger pop up ? Could it be some option at the internet explorer level ?

thanks,

-- Thibaut
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/ironruby-core/attachments/20080409/919a103b/attachment.html 


More information about the Ironruby-core mailing list