[Ironruby-core] problems with new rakefile require 'pathname2'

Eric Nicholson enicholson at gmail.com
Wed Sep 26 13:25:38 EDT 2007


The tests run now, but a lot of the tests are being skipped.   Is there some
easy way I can get those going?

The reason I ask is that I'm trying to get a DSL built on IronRuby, and I
needed to make some tweaks to Kernel & RubyOps to get all the scoping
resolved right.  I just want to make sure I haven't broken anything too
important :)

Thanks!
Eric

On 9/26/07, John Lam (DLR) <jflam at microsoft.com> wrote:
>
>  Hi Eric,
>
>
>
> Those are our internal tests, which don't use the same logic that the
> Rakefile uses to determine where they're being run from. For the time being
> I'm going to disable those tests and open a bug against Haibo who owns that
> test suite.
>
>
>
> Thanks!
>
> -John
>
>
>
>
>
> *From:* ironruby-core-bounces at rubyforge.org [mailto:
> ironruby-core-bounces at rubyforge.org] *On Behalf Of *Eric Nicholson
> *Sent:* Tuesday, September 25, 2007 6:05 PM
> *To:* ironruby-core at rubyforge.org
> *Subject:* Re: [Ironruby-core] problems with new rakefile require
> 'pathname2'
>
>
>
> What value do we need to have for "MERLIN_ROOT"?  I'm getting errors in
> common.rb when running the test suite:
>
> c:/source/ironruby/trunk/tests/ironruby/common.rb:25: undefined method `+'
> for nil:NilClass (NoMethodError)
>         from
> c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
> `gem_original_require'
>         from
> c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
>         from run.rb :5
>
> -Eric
>
> On 9/25/07, *Eric Nicholson* <enicholson at gmail.com> wrote:
>
> The build works much better now.  Thanks!
>
> Any chance we could get that as a "require_gem" in a future release?
>
> On 9/25/07, *John Lam (DLR)* <jflam at microsoft.com> wrote:
>
>   It's a gem – just gem install pathname2.
>
>
>
> Thanks,
>
> -John
>
>
>
>
>
> *From:* ironruby-core-bounces at rubyforge.org [mailto:
> ironruby-core-bounces at rubyforge.org] *On Behalf Of *Eric Nicholson
> *Sent:* Tuesday, September 25, 2007 5:24 PM
> *To:* ironruby-core at rubyforge.org
> *Subject:* [Ironruby-core] problems with new rakefile require 'pathname2'
>
>
>
> When I run the updated rakefile I get "no such file to load --
> pathname2".  Is it possible that this file wasn't added to SVN in the last
> update?
>
> -Eric
>
>
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>
>
>
>
>
> _______________________________________________
> Ironruby-core mailing list
> Ironruby-core at rubyforge.org
> http://rubyforge.org/mailman/listinfo/ironruby-core
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/ironruby-core/attachments/20070926/58eefc34/attachment.html 


More information about the Ironruby-core mailing list