[Instiki] Instiki 0.16 does not work on Ubuntu 8.10

Jacques Distler distler at golem.ph.utexas.edu
Tue Mar 31 17:46:56 EDT 2009


On Mar 31, 2009, at 2:39 PM, tchomby wrote:

> The error below happens with 0.16.5 and 0.16.3 but not 0.13.
>
> seanh at kisimul:$ ruby instiki
> => Booting WEBrick
> => Rails 2.3.2 application starting on http://0.0.0.0:2500
> ./script/../config/../vendor/rails/railties/lib/initializer.rb:269:in
> `require_frameworks': no such file to load -- net/https (RuntimeError)
> 	from ./script/../config/../vendor/rails/railties/lib/initializer.rb: 
> 134:in
> `process'

Net/https is a standard Ruby package (required by Rails). It should  
have come with your Ruby installation. I gather that, on some (?)  
Ubuntu installations, you need to install the libopenssl-ruby1.8  
package to get it:
      apt-get install libopenssl-ruby

see, e.g.:

     http://blade.nagaokaut.ac.jp/cgi-bin/scat.rb/ruby/ruby-talk/255066
-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 253 bytes
Desc: This is a digitally signed message part
URL: <http://rubyforge.org/pipermail/instiki-users/attachments/20090331/3e50f111/attachment.bin>


More information about the Instiki-users mailing list