[Instiki] published version

Christian Simonutti csimonut at gmail.com
Thu Jun 1 17:00:20 EDT 2006


Hi John,

thank you for the response. Seems like instiki is still alive. I already
tried to get an trac account, but got no response from Alexey until now.

Sorry for beeing so unprecise in my last mail, I will try to give you a
summary about bugs I know.

> http://dev.instiki.org/ticket/243

I have reported this bug and sent a fix to Alexey, it's already in head:
http://dev.instiki.org/changeset/477

> http://dev.instiki.org/ticket/244

Hmm, maybe this is an issue i will explain later.

> http://dev.instiki.org/ticket/293

I cannot reproduce this bug with 0.11.0, I get a "Page 'authors' not
found" when accessing "/wiki/published/authors"


The attached patch fixes the bug described at
http://www.instiki.org/show/Tips+and+Tricks:
"When in the /published/ version (read only mode): links in the side bar
still point to the /show/ version (editable mode)."


I'm running instiki with WEBrick behind an Apache configured with two
virtual hosts (no mod_rewrite) as described at
http://www.instiki.org/show/HowToUseInstikiAsWebSite:

*.mydomain.com:
ProxyPass /wiki/published/ http://localhost:2500/wiki/published/
ProxyPass / http://localhost:2500/wiki/published/
ProxyPassReverse / http://localhost:2500/wiki/published/

edit.mydomain.com
ProxyPass / http://localhost:2500/
ProxyPassReverse / http://localhost:2500/


I think the main problem is the combination of mod_proxy and /published/
in the Url, because that causes wrong Urls to be generated:

1) !/images/imagename.gif!
the Url works in "normal" mode, but with /wiki/published the Url is wrong
and produces a 404:
/wiki/published/images/imagename.gif (should be /images/imagename.gif)

2) The same error occures with rss-Feeds. mod_proxy inserts
/wiki/published/ and it also produces a 404.

I think this is a conceptional problem with this kind of setup (or in
general?). Maybe a quick solution would be to get rid '/published' and
render a published version (at the same url) if the wiki is
- configured for published mode and
- the user is not logged in

These kind of errors do not occur when going directly to the WEBrick
server, with no Apache in front.


Sometimes caching works strange. Start instiki with caching disabled and
edit a page. It work as expected. Afterwards start instiki with caching
enabled, you wont see the change you made when caching was disabled.
Switch between caching enabled and disabled and always edit a page. The
change made when caching was disabled will not be shown when startet with
caching enabled afterwards. (I hope you understand what I mean, hard to
describe.) Don't think, this is the correct behaviour.


Regards,
Simon
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: includerb_patch.txt
Url: http://rubyforge.org/pipermail/instiki-users/attachments/20060601/823067b0/attachment.txt 


More information about the Instiki-users mailing list