[Instiki] problem instiki on textdrive

Alexey Verkhovsky alex at verk.info
Wed Jun 1 18:15:20 EDT 2005


Denis Lamotte wrote:

> when i launch instiki on textrive trough the command line with:
> --command--
> ruby /home/myhome/instiki/instiki.rb --daemon --port 2508 --storage 
> /home/myhome/instiki/storage/ -b 70.84.216.2
> --command--
> or shoob.net instead of 70.84.216.2
>
> sometimes it work, sometimes not but event when it worked i 've an 
> rails error when trying to submiting the first form create_system.

Looks like --daemon option is broken now. Having thought about it for a 
while, I'm fairly confident that all these problems are caused by 
starting the Madeleine thread before the fork.

If anybody knows how to pass some initialization block to WEBRick (to be 
executed after the fork), please tell me or send me a patch. I haven't 
figured it out so far. Madeleine thread in this line:
  ApplicationController.wiki = WikiService.instance

Otherwise, the only solution I see at the moment is to copy/paste the 
forking code from WEBRick::Daemon#start into script/server, right after 
options parsing. Ugly, but would do the trick also.

By the way, another good topic for a patch (along the same lines of "how 
do I run Instiki in a production environment") is some option(s) to 
control logging. Something like

--log '/path/to/log'
and maybe also
--access_log '/path/to/access_log'
for people who want access.log to be separated from all the Rails logging.
May be also some option(s) to limit the verboseness of the Rails log (by 
default it's quite talkative).

-- 
Best regards,

Alexey Verkhovsky

Ruby Forum: http://ruby-forum.org        (moderator)
RForum:     http://rforum.andreas-s.net  (co-author)
Instiki:    http://instiki.org           (maintainer)



More information about the Instiki-users mailing list