[Instantrails-users] localhost running application problem

Giorgio Clavelli giorgio.clavelli at gmail.com
Sat Jul 5 19:03:44 EDT 2008


 Hi,

As I never seen that problem, I start up InstantRails and tried your
same steps. From the "Rails Applications" window, I selected cookbook
and started mongrel with no error. However, when then I pointed the
browser to http://localhost:3000/ I surprisingly got an 404 error from
the browser. So I stopped mongrel and repeated the process with an
application I'm playing with (actually it is for a very nice tutorial
on ror routing:
http://darynholmes.wordpress.com/2008/03/15/beginners-tutorial-routing-in-rails-20-with-rest-part-1-of-n/)
and I haven't come across with any problem when I then went to
http://localhost:3000/. So, I tried again with cookbook and noticed
that it weirdly run on http://localhost:3001/. When I pointed the
browser there, the cookbook worked nicely (it goes straight to the app
home page as the rails welcome page has been removed from it).
While I don't have the solution to your specific problem, as I never
seen your error, it may be an environmental problem.
I'm using Win XP and when I launch a "hello world" basic app (it has
only a controller and relative view) its rails "welcome" page's "About
your application's environment" link show this:

Ruby version 1.8.6 (i386-mswin32)
RubyGems version 1.0.1
Rails version 2.0.2
Active Record version 2.0.2
Action Pack version 2.0.2
Active Resource version 2.0.2
Action Mailer version 2.0.2
Active Support version 2.0.2
Application root E:/INSTAN~1.0-W/rails_apps/testapp
Environment development
Database adaptersqlite3

Another possible source of problem may be you are already using the
port 3000 with another app
Also, your copy of InstantRails zip file, may have been corrupted,
while downloading

but these a long shots.

On Sun, Jul 6, 2008 at 3:39 AM, Mateusz Winiarski <mawiniarski at gmail.com> wrote:
>
> Greetings,
>
> I'm trying to browse local webpage using InstantRails 2.0
>
> -> open Rails Applications
> -> choose one app (Cookbook - default one)
> -> press "Start with Mongrel"
> -> open Firefox 3.0
> -> browse: http://localhost:3001/ (waiting....)
> -> in console there is infinite loop:
>         mongrel_rails.rb:19: Unhandled listen loop exception #(Errno::ENOTSOCK: An operation was attempted on something that is not a socket.).
>
> Any ideas ??
>
> THX
>
> Mateusz Winiarski
> www.winiarski.ugu.pl
> www.mawiniarski.net78.net
>
> _______________________________________________
> Instantrails-users mailing list
> Instantrails-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/instantrails-users


More information about the Instantrails-users mailing list