[Instantrails-users] Problem Installing RMagick with Instant Rails on Windows

Walter LOCKHART walterlockhart at gmail.com
Thu Nov 22 07:15:30 EST 2007

I'm running Instant Rails 1.4 on Windows XP with SP2.

I have downloaded the Windows binary version of RMagick from the RubyForge

Specifically, I have downloaded:

1.14.1 binary gem for Ruby 1.8.5 (fixed for RubyGems 0.9.4)

I have removed any older versions of RMagick using:

gem uninstall RMagick

I have updated my version of rubygems.

I executed the ImageMagick installer found in the zip file and selected the
"Update executable search path" from the installation options.

I then installed the gem:

gem install rmagick --local

and received the response:

Successfully installed rmagick-1.14.1-unknown
1 gem installed

Unfortunately, when I type the following at a Rails Console prompt:

>> require 'RMagick'

I receive the response:

require 'RMagick'MissingSourceFile: no such file to load -- RMagick

Similarly, when I attempt to use RMagick within my Rails application (I use
it to resize an uploaded image) I get the following message:

Problems loading rmagickProcessor: no such file to load -- RMagick

When I place the line:

require 'RMagick'

in the application's environment.rb the application fails with the message:

`gem_original_require': no such file to load --

RMagick (MissingSourceFile)

I have been searching the Internet for days now and I still can't seem to
make progress.  Can anyone out there please help me?

Thanks in advance.

Kind Regards

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/instantrails-users/attachments/20071122/dd898a6d/attachment.html 

More information about the Instantrails-users mailing list