[Instantrails-users] Problem installing plugin

Curt Hibbs curt.hibbs at gmail.com
Mon Sep 18 13:10:46 EDT 2006

On 9/18/06, Bill Walton <bill.walton at charter.net> wrote:
>  Is there a 'trick' to installing plugins under IR?  I'm getting an error
> I don't understand when I try to install the BackgrounDRb plugin (this is
> the first plugin I've tried to install).
> I installed the plugin yesterday, or thought I did, and this morning I
> tried to start the backgroundrb daemon (from the sandbox directory I entered
> >ruby script\backgroundrb\start.  I got an error message saying 'no such
> file or directory -- script/backgroundrb/start (LoadError)'.
> So tried to reinstall the plugin using:
> >ruby script\plugin install svn://rubyforge.org//var/svn/backgroundrb
> --force
> During the download\install, the first line of the reponse says:
> svn: 'C:\InstantRails\rails_apps\sandbox\vendor\plugins' is not a working
> copy
> Then it goes ahead and creates vendor\plugins\backgroundrb directory with
> subdirectories, etc.  But I still get the 'no such file' error when I try to
> start the daemon.
> Question is: what's not a working copy? Is it talking about the already
> installed version?  Or is it telling me there's something wrong with my IR
> install?   Anybody got any idea what I'm doing wrong?
> Thanks!
> Bill

Do you have another copy of Ruby installed besides the one in Instant Rails?
If so, is the Instant Rails version the first one in your system path (that
is, is its ...\ruby\bin directory first in your path)?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/instantrails-users/attachments/20060918/5593470f/attachment-0001.html 

More information about the Instantrails-users mailing list