[Instantrails-users] Error creating controllers in InstantRails-1.3a

Curt Hibbs curt.hibbs at gmail.com
Mon May 15 15:59:43 EDT 2006

On 5/15/06, Pankaj Agarwal <pa_inbox at yahoo.com> wrote:
> Hi,
> I was able to successfully Install InstantRails-1.3a and run cookbook
> throgh Apache and WEBrick , however when I try to create my own app.
> cookbook2 following tutorial (http://instantrails.rubyforge.org/tutorial/index.html)
> , it gives me below error whle creating MyTest controller
> Cannot find gem for Rails =1.1.2:
>     Install the missing gem with 'gem install -v=1.1.2 rails', or
>     change environment.rb to define RAILS_GEM_VERSION with your desired
> version.
> I looked at environment.rb of cookbook and it does NOT define
> RAILS_GEM_VERSION, however cookbook2's environment.rb DOES define it, when
> I make it same as cookbook's ( i.e. comment it ) then I get below error
> E:\InstantRails\rails_apps\cookbook2>ruby script\generate controller
> MyTest
> E:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:204:in `report_activate_error':
> Could
>  not find RubyGem rails (> 0.0.0) (Gem::LoadError)
>         from E:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:141:in `activate'
>         from E:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:37:in
> `require_gem_with_
> options'
>         from E:/ruby/lib/ruby/site_ruby/1.8/rubygems.rb:31:in
> `require_gem'
>         from ./script/../config/boot.rb:38
>         from
> E:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in `re
> quire'
>         from script/generate:2
> What am I missing here ??
> -TIA
>  Pankaj

Sounds like something is messed up in your Instant Rails tree.

I would unzip a fresh copy to a *new* directory and try it there. I just did
that myself to  try to reproduce your problem, but it worked just fine.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/instantrails-users/attachments/20060515/fa83a28c/attachment.htm 

More information about the Instantrails-users mailing list