[Instantrails-users] Ruby slooooow.. Please help!

Curt Hibbs curt.hibbs at gmail.com
Sun Jul 30 00:27:39 EDT 2006

On 7/29/06, Gene Horodecki <malibu66 at gmail.com> wrote:
> Whenever I do anything at all that involves Ruby there seems to be around
> a five to ten second delay before anything happens.. This includes running
> script/generate, or rendering pages...  It's quite annoying, I'm really
> hoping someone knows what it may be.  My dev laptop isn't the fastest.. 1
> Ghz T23 thinkpad with 512 MB RAM.. but it shouldn't be THAT slow.  I've
> installed InstantRails 1.3a (PHP 4) and have the SGCI server running for
> my app.. Port 9996.
This has been reported before. Here's a repost of one person's solution:

From: Joerg Diekmann <joergd at pobox.com>
Date: Jul 5, 2006 7:41 AM
Subject: [Rails] Re: Performance (cough cough) Poor: Instant Rails
To: rails at lists.rubyonrails.org

Hi Greg,

I had the same problem. I solved it by changing my .htaccess file.

I changed this line:

RewriteRule ^(.*)$ dispatch.cgi [QSA,L]


RewriteRule ^(.*)$ dispatch.fcgi [QSA,L]

That speeded things up a lot running my apps with scgi and InstantRails.
I noticed it because my Cookbook app was fast, but any new ones I added
were slow. This was one of the few files that would be different and
could affect the way Rails works.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/instantrails-users/attachments/20060729/c2e10034/attachment-0001.html 

More information about the Instantrails-users mailing list