[Instantrails-users] browser connection issue to http://localhost:3000/ on XP ?

Curt Hibbs curt.hibbs at gmail.com
Mon Jul 17 09:28:16 EDT 2006


No... this is the first I've ever seen of this.

Curt

On 7/14/06, gregsfm at tpg.com.au <gregsfm at tpg.com.au> wrote:
>
> Update - Got things working by using "netsh winsock reset".  BTW: Does
> this make any sense to anyone?
>
> Reference:
> http://networksecurityarchive.org/html/NTBugtraq/2004-08/msg00041.html
>
>
>
> Quoting gregsfm at tpg.com.au:
> >
> >
> > http://www.ruby-forum.com/topic/73035#new
> >
> >
> > Hi,
> >
> > I think I have network issue on my XP PC here trying to run up
> > InstantRails and using it.  I create an application and run up the
> > server "ruby scripts/server" and it runs up, but then when I try to
> > browse to it the browser just sits and spins and doesn't connect  :(
> >
> > Note that I posted this at
> > http://www.ruby-forum.com/topic/73035#new however (a) no luck yet
> > and
> > (b) perhaps this is an instantrails related issue???
> >
> > * I've tried: localhost:3000, 127.0.0.0:3000, 127.0.0.1:3000 + the IP
> >
> > address that "ipconfig" reports but no luck.
> >
> > * I did have ZoneAlarm installed but I deinstalled this and
> > restarted.
> >
> > * I did a month ago come across this problem and someone had posted a
> >
> > windows command prompt line that did something like clear the XP
> > network
> > connections or something, however now I can't find this again :(
> >
> > Can anyone help / give pointers re getting my browser to be able to
> > connect to webbrick on XP?    (sounds stupid I know, but I'm
> > stumped)
> >
> > Thanks in advance
> > ===================
> > <cut>thanks, but I think none of these help - can anyone shed any
> > light on
> > this one?  Is there another network level diagnostic or reset I can
> > run
> > to see what's going on between the browser and the webrick server?
> > OS
> > again is Windows XP.
> >
> > [1] hosts file is good
> > 127.0.0.1       localhost
> > 127.0.0.1       www.mycookbook.com
> >
> > [2] ipconfig /flushdns => didn't help - this wasn't the command I had
> >
> > found previously that made things work I don't think (i.e. the one
> > which
> > I now can't find on the net)
> >
> > [3] Windows XP firewall is off, and I've deinstalled zonealarm
> >
> > [4] Also if this helps here is an netstat output - you can see that
> > the
> > browser does seemed to have triggered a TCP connection to the laptop
> > I
> > guess (?)
> > ----------
> > C:\Gregs\INSTAN~1\rails_apps>netstat
> > Active Connections
> >   Proto  Local Address          Foreign Address        State
> >   TCP    FREDS_LAPTOP:1180      localhost:1181         ESTABLISHED
> >   TCP    FREDS_LAPTOP:1181      localhost:1180         ESTABLISHED
> >   TCP    FREDS_LAPTOP:1365      localhost:3000         ESTABLISHED
> >   TCP    FREDS_LAPTOP:3000      localhost:1365         ESTABLISHED
> > ----------
> >
>
> ===========================================================================
> > Active Routes:
> > Network Destination        Netmask          Gateway       Interface
> > Metric
> >           0.0.0.0          0.0.0.0      192.168.0.2   192.168.0.101
> > 25
> >         127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1
> > 1
> >       192.168.0.0    255.255.255.0    192.168.0.101   192.168.0.101
> > 25
> >     192.168.0.101  255.255.255.255        127.0.0.1       127.0.0.1
> > 25
> >     192.168.0.255  255.255.255.255    192.168.0.101   192.168.0.101
> > 25
> >         224.0.0.0        240.0.0.0    192.168.0.101   192.168.0.101
> > 25
> >   255.255.255.255  255.255.255.255    192.168.0.101   192.168.0.101
> > 1
> >   255.255.255.255  255.255.255.255    192.168.0.101               2
> > 1
> >   255.255.255.255  255.255.255.255    192.168.0.101               4
> > 1
> > Default Gateway:       192.168.0.2
> >
>
> ===========================================================================
> >
> > thanks again
> >
> > _______________________________________________
> > Instantrails-users mailing list
> > Instantrails-users at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/instantrails-users
> >
> >
> >
>
>
> _______________________________________________
> Instantrails-users mailing list
> Instantrails-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/instantrails-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/instantrails-users/attachments/20060717/42d75267/attachment.html 


More information about the Instantrails-users mailing list