[Instantrails-users] No Instant Gratification ! Browser can't access localhost:3000 (IR 1.4)

Curt Hibbs curt.hibbs at gmail.com
Thu Dec 7 14:49:49 EST 2006

On 12/7/06, Harrivel <gharrivel at free.fr> wrote:
> Hi! I'm learning Ruby on Rails with the Agile Web Development With Rails
> book. I have installed InstantRails 1.4 (under windows xp 2) and after
> doing all steps (gem updates, rails demo, ruby script/server which
> launches WEBrick server), I can't access the localhost:3000 with the
> browser. I tried in apache config, then with my IP
> address (given by DHCP, I'm behind an ADSL router)
> Firefox says he can't etablish any connexion with the server at this
> address.
> I tried also to "listen 3000" to apache config, but the browser goes to
> InstantRails/www/index.html...  I've modified also the wondows etc/hosts
> file...Please, help me!

When you launch the WEBrick server and browse directly to Apache isn't involved at all, so don't waste your
time messing with apache configuration.

Try this:

- Unzip a fresh copy of Instant Rails 1.4 (to make sure you're starting

- Start the Instant Rails manager (instalrails.exe), and make sure that the
MySQL server starts up (Apache doesn't matter, because you won't be using

- Open a Ruby Console Windows through the Instant Rails menus (this is
important because it puts IT's copy of Ruby on the system path in that

- Move into the preinstalled cookbook sample app (i.e., "cd cookbook").

- Start WEBrick (i.e., "ruby script\server")

- Wait WEBrick to say it is listening on port 3000, and then browse to

You should see the cookbook app. If you don't, post the console log from
WEBrick and we should be able to figure out what's going on.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/instantrails-users/attachments/20061207/de0c69b6/attachment-0001.html 

More information about the Instantrails-users mailing list