[Instantrails-users] Can't Get InstantRails Default Applications to Work

David Morton mortonda at dgrmm.net
Sun Aug 6 17:19:46 EDT 2006


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

a friend wrote:
> installation and troubleshooting process.  Does
> anybody have any idea on what is wrong?

I see a few things so far...

> 
> First I extracted InstantRails 1.3a to
> C:\InstantRails.
> 
> Before I started InstantRails, I went to the Apache
> directory and started Apache.  I got this message:

Um, why?  that's not the documented way to do it.  Running the IR manager first
rewrites the document root, which is why you got the next error...

> 
> 	Syntax error on line 74 of
> c:/instantrails/apache/conf/httpd.conf:
> 	ServerRoot must be a valid directory
> 
> Then I started InstantRails and got this message in a
> popup window:
> 
> 	Apache port (80) is used by "" (inetinfo.exe)!

Ahh, you are running IIS, which interferes with apache. You can only have one
web server on port 80.  So it looks like you changed the port... good ....

> 
> Next, I went to Configure > Apache and changed the
> Port and Listen to 3000:
> 
> 	Port 3000
> 	Listen 3000

I think that looks right, but I haven't tested it. At this point, apache needs
to be restarted...

> 
> I also went into the Windows Host file and added these
> lines:
> 
> 	127.0.0.1	localhost
> 	127.0.0.1	www.mycookbook.com
> 	127.0.0.1	typo
> 
> Now when I restarted IR and opened the Rails
> Application window, I checked the checkbox next to
> cookbook and clicked the "Start SCGI Server" button. 
> When I entered http://www.mycookbook.com, I got the
> Internet site, not the local Rails application.

Sounds like some sort of proxy is interfering with dns lookups, and ignoring the
hosts file...


> Next I entered http://127.0.0.1:3000/ and the browser
> displayed the message "coming soon!" which is coming
> from C:\InstantRails\www\index.html.
> 
> Now I opened up the Windows Hosts file again and
> changed the ports for the RoR applications:
> 
> 	127.0.0.1		localhost
> 	127.0.0.1:3000	www.mycookbook.com
> 	127.0.0.1:3000	typo

That's not a valid format for a hosts file.  The hosts file has no bearing on
ports or services, only name to IP mappings.  I don't know what happens when you
 put an invalid format like this in.

> Then I restarted IR, went to Manage Rails
> Applications, checked the cookbook application
> checkbox, and clicked the "Start SCGI Server" button.

Did a command window come up and stay up?

> This time when I started the cookbook application with
> the URL http://www.mycookbook.com:3000/, my Firefox
> browser said "The connection has timed out."  I also
> tried it in IE but got the message, "The page cannot
> be displayed" and "Cannot find server or DNS Error".

We've got compounding errors at this point, so it's hard to say what's going on.

> C:\InstantRails>netstat -a
> 
> 	Active Connections
> 
> 	  Proto  Local Address          Fore
> 	  TCP    LLC30-E00008034:smtp   LLC3
> 	  TCP    LLC30-E00008034:http   LLC3
> 	  TCP    LLC30-E00008034:epmap  LLC3
> 	  TCP    LLC30-E00008034:https  LLC3
> 	  TCP    LLC30-E00008034:microsoft-d
> 	TENING
> 	  TCP    LLC30-E00008034:1035   LLC3
> 	  TCP    LLC30-E00008034:1351   LLC3
> 	  TCP    LLC30-E00008034:1039   LLC3
> 	  TCP    LLC30-E00008034:1057   LLC3
> 	  TCP    LLC30-E00008034:1118   loca
> 	  TCP    LLC30-E00008034:1119   loca
> 	  TCP    LLC30-E00008034:1352   LLC3
> 	  TCP    LLC30-E00008034:ms-sql-s  L
> 	NG
> 	  TCP    LLC30-E00008034:62514  LLC3
> 	  TCP    LLC30-E00008034:netbios-ssn
> 	ENING
> 	  TCP    LLC30-E00008034:ms-sql-s  L
> 	NG	
> 	  TCP    LLC30-E00008034:52028  LLC3
> 	  UDP    LLC30-E00008034:407    *:*
> 	  UDP    LLC30-E00008034:microsoft-d
> 	  UDP    LLC30-E00008034:isakmp  *:*
> 	  UDP    LLC30-E00008034:1025   *:*
> 	  UDP    LLC30-E00008034:1026   *:*
> 	  UDP    LLC30-E00008034:1033   *:*
> 	  UDP    LLC30-E00008034:1079   *:*
> 	  UDP    LLC30-E00008034:2967   *:*
> 	  UDP    LLC30-E00008034:3456   *:*
> 	  UDP    LLC30-E00008034:4500   *:*
> 	  UDP    LLC30-E00008034:52311  *:*
> 	  UDP    LLC30-E00008034:ntp    *:*
> 	  UDP    LLC30-E00008034:1060   *:*
> 	  UDP    LLC30-E00008034:1159   *:*
> 	  UDP    LLC30-E00008034:1191   *:*
> 	  UDP    LLC30-E00008034:1900   *:*
> 	  UDP    LLC30-E00008034:62514  *:*
> 	  UDP    LLC30-E00008034:ntp    *:*
> 	  UDP    LLC30-E00008034:netbios-ns
> 	  UDP    LLC30-E00008034:netbios-dgm
> 	  UDP    LLC30-E00008034:1900   *:*
> 	  UDP    LLC30-E00008034:52029  *:*

I don't see 3000 on there, so I suspect there's something wrong with apache.  Is
there anything in the apache logs in InstantRails/apache/logs/  ?


> 
> I tried changing this file
> C:\InstantRails\rails_apps\cookbook\config\scgi.yaml
> from
> 
> 	:host: 127.0.0.1
> 
> to
> 
> 	:host: 127.0.0.1:3000

That is invalid, it is expecting a hostname only.

Please revert your hosts file back to the original, delete the IR tree and start
over.  This time, disable your IIS Server (Or if you can't, then change the port
like above in the apache.conf file) and follow the online instructions.






- --
David Morton
Maia Mailguard                        - http://www.maiamailguard.com
Morton Software Design and Consulting - http://www.dgrmm.net
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFE1lzyUy30ODPkzl0RAuHHAKDOpeSpOwmT9aIBR+aBZWY7YNq8WwCfacWA
+s8Eq4O8cC48oswficl2x3M=
=hkL7
-----END PGP SIGNATURE-----


More information about the Instantrails-users mailing list