[Instantrails-users] Can't Get InstantRails Default Applications to Work

gregsfm at tpg.com.au gregsfm at tpg.com.au
Sat Aug 5 07:44:29 EDT 2006


It may be the problem I've experienced, somewhere in the winsock layer.
Try entering the following whilst logged into a windows accoutn with
ADMIN rights:

   netsh winsock reset

Run up webbrick after this and try again.  For me this would fix it.  
Don't ask me what the problem really is or why the above works  :)

Cheers
Greg


Quoting Curt Hibbs <curt.hibbs at gmail.com>:

> Is your browser configured to use a proxy server? If so, then the
> HOSTS
> definition of www.mycookbook.com will be igored and a real DNS
> lookup
> through the proxy server will result in the real internet site
> instead of
> your local machine.
> 
> This happens to me when I'm on my work machine. If so, just
> temporarily turn
> off the proxy server setting and it should start working as
> expected.
> 
> Curt
> 
> On 8/4/06, a friend <desperado9 at yahoo.com> wrote:
> >
> >
> > I have a Windows XP Professional machine with Service
> > Pack 2 on it.  I've downloaded and installed the
> > latest InstantRails distro but I can't get either the
> > cookbook or typo applications to work.  When I try to
> > access them, they just time out.  Here's my entire
> > installation and troubleshooting process.  Does
> > anybody have any idea on what is wrong?
> >
> > First I extracted InstantRails 1.3a to
> > C:\InstantRails.
> >
> > Before I started InstantRails, I went to the Apache
> > directory and started Apache.  I got this message:
> >
> >         Syntax error on line 74 of
> > c:/instantrails/apache/conf/httpd.conf:
> >         ServerRoot must be a valid directory
> >
> > Then I started InstantRails and got this message in a
> > popup window:
> >
> >         Apache port (80) is used by "" (inetinfo.exe)!
> >
> > Next, I went to Configure > Apache and changed the
> > Port and Listen to 3000:
> >
> >         Port 3000
> >         Listen 3000
> >
> > I also went into the Windows Host file and added these
> > lines:
> >
> >         127.0.0.1       localhost
> >         127.0.0.1       www.mycookbook.com
> >         127.0.0.1       typo
> >
> > Now when I restarted IR and opened the Rails
> > Application window, I checked the checkbox next to
> > cookbook and clicked the "Start SCGI Server" button.
> > When I entered http://www.mycookbook.com, I got the
> > Internet site, not the local Rails application.
> >
> > Next I entered http://127.0.0.1:3000/ and the browser
> > displayed the message "coming soon!" which is coming
> > from C:\InstantRails\www\index.html.
> >
> > Now I opened up the Windows Hosts file again and
> > changed the ports for the RoR applications:
> >
> >         127.0.0.1               localhost
> >         127.0.0.1:3000  www.mycookbook.com
> >         127.0.0.1:3000  typo
> >
> > Then I restarted IR, went to Manage Rails
> > Applications, checked the cookbook application
> > checkbox, and clicked the "Start SCGI Server" button.
> >
> > This time when I started the cookbook application with
> > the URL http://www.mycookbook.com:3000/, my Firefox
> > browser said "The connection has timed out."  I also
> > tried it in IE but got the message, "The page cannot
> > be displayed" and "Cannot find server or DNS Error".
> >
> > Next I went to the Apache directory and started Apache
> > by hand.  There were no errors reported.
> >
> > Next I stopped my Windows firewall and tried
> > http://www.mycookbook.com:3000/ again in both Firefox
> > and IE and got the same messages as before.  There's
> > nothing in the Apache Error and Access logs and the
> > InstantRails log looks normal:
> >
> >         03/08 21:00:22 Instant Rails: Servers starting
> >         03/08 21:00:23 Apache : Apache port (80) is used by
> > "" (inetinfo.exe) !
> >         03/08 21:00:23 MySql  : Configuration file changed
> >         03/08 21:00:23 Apache : Configuration file changed
> >         03/08 21:06:08 Apache : Configuration file changed
> >         03/08 21:06:20 Instant Rails: Stop the Servers
> >         03/08 21:06:31 Instant Rails: Servers starting
> >         03/08 21:16:54 Instant Rails: Stop the Servers
> >         03/08 21:17:17 Instant Rails: Servers starting
> >         03/08 21:19:44 Instant Rails: Stop the Servers
> >         03/08 21:19:49 Instant Rails: Servers starting
> >         03/08 21:28:27 Instant Rails: Stop the Servers
> >         03/08 21:31:08 Instant Rails: Servers starting
> >
> > When I do a "netstat -a" this is what I see:
> >
> >
> > C:\InstantRails>netstat -a
> >
> >         Active Connections
> >
> >           Proto  Local Address          Fore
> >           TCP    LLC30-E00008034:smtp   LLC3
> >           TCP    LLC30-E00008034:http   LLC3
> >           TCP    LLC30-E00008034:epmap  LLC3
> >           TCP    LLC30-E00008034:https  LLC3
> >           TCP    LLC30-E00008034:microsoft-d
> >         TENING
> >           TCP    LLC30-E00008034:1035   LLC3
> >           TCP    LLC30-E00008034:1351   LLC3
> >           TCP    LLC30-E00008034:1039   LLC3
> >           TCP    LLC30-E00008034:1057   LLC3
> >           TCP    LLC30-E00008034:1118   loca
> >           TCP    LLC30-E00008034:1119   loca
> >           TCP    LLC30-E00008034:1352   LLC3
> >           TCP    LLC30-E00008034:ms-sql-s  L
> >         NG
> >           TCP    LLC30-E00008034:62514  LLC3
> >           TCP    LLC30-E00008034:netbios-ssn
> >         ENING
> >           TCP    LLC30-E00008034:ms-sql-s  L
> >         NG
> >           TCP    LLC30-E00008034:52028  LLC3
> >           UDP    LLC30-E00008034:407    *:*
> >           UDP    LLC30-E00008034:microsoft-d
> >           UDP    LLC30-E00008034:isakmp  *:*
> >           UDP    LLC30-E00008034:1025   *:*
> >           UDP    LLC30-E00008034:1026   *:*
> >           UDP    LLC30-E00008034:1033   *:*
> >           UDP    LLC30-E00008034:1079   *:*
> >           UDP    LLC30-E00008034:2967   *:*
> >           UDP    LLC30-E00008034:3456   *:*
> >           UDP    LLC30-E00008034:4500   *:*
> >           UDP    LLC30-E00008034:52311  *:*
> >           UDP    LLC30-E00008034:ntp    *:*
> >           UDP    LLC30-E00008034:1060   *:*
> >           UDP    LLC30-E00008034:1159   *:*
> >           UDP    LLC30-E00008034:1191   *:*
> >           UDP    LLC30-E00008034:1900   *:*
> >           UDP    LLC30-E00008034:62514  *:*
> >           UDP    LLC30-E00008034:ntp    *:*
> >           UDP    LLC30-E00008034:netbios-ns
> >           UDP    LLC30-E00008034:netbios-dgm
> >           UDP    LLC30-E00008034:1900   *:*
> >           UDP    LLC30-E00008034:52029  *:*
> >
> > I tried changing this file
> > C:\InstantRails\rails_apps\cookbook\config\scgi.yaml
> > from
> >
> >         :host: 127.0.0.1
> >
> > to
> >
> >         :host: 127.0.0.1:3000
> >
> > Even this didn't work!!!  HELP!!!  What's wrong????
> >
> >
> >
> >
> >
> >
> > __________________________________________________
> > Do You Yahoo!?
> > Tired of spam?  Yahoo! Mail has the best spam protection around
> > http://mail.yahoo.com
> > _______________________________________________
> > Instantrails-users mailing list
> > Instantrails-users at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/instantrails-users
> >
> 




More information about the Instantrails-users mailing list