[Instantrails-users] REXML question

Bill Walton bill.walton at charter.net
Sat Apr 29 12:40:54 EDT 2006


Curt, David, Gavin;

Thanks guys.  I got thrown by the <UNDEFINED> output.  It's not shown in the tutorial so I figured it was an error of some sort.  You're all right.  After reading Gavin's response (because it came in first) I restarted and just kept going and everything works fine.  It turns out, though, that the <UNDEFINED> output isn't the only thing irb is outputting that's not in the tutorial.  I *hate* it when that happens ;-|

Anyway, now that I can see how it works, I'm on to using RoR to do a little test app.  Read in an XML file using REXML, store the contents in the db, then use Builder to write out a copy.

Thanks again,
Bill
  ----- Original Message ----- 
  From: Curt Hibbs 
  To: instantrails-users at rubyforge.org 
  Sent: Saturday, April 29, 2006 10:52 AM
  Subject: Re: [Instantrails-users] REXML question


  On 4/29/06, David Morton <mortonda at dgrmm.net> wrote:
    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    Bill Walton wrote:

    > irb(main):003:0> doc=REXML::Document.new file
    > => <UNDEFINED> ... </>
    > [BW]  I assume the <UNDEFINED> error message above is referring to 
    > Document.  One thing I don't understand though is why the 'require' on

    I don't think that's an error, I think <UNDEFINED> is part of the XML object.
    Irb tries to output some descriptive text about the object.  So this is normal. 

    Indeed, I tried a "puts doc"  next, and it printed the document.


  Yes, David is correct. I tried "doc.methods" and got a nice list of all the REXML Document methods.

  Curt



------------------------------------------------------------------------------


  _______________________________________________
  Instantrails-users mailing list
  Instantrails-users at rubyforge.org
  http://rubyforge.org/mailman/listinfo/instantrails-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/instantrails-users/attachments/20060429/c31c6573/attachment-0001.htm 


More information about the Instantrails-users mailing list