[Instantrails-users] uninitialized constant WEBrick

Tim Uckun timuckun at gmail.com
Sat Apr 15 00:59:15 EDT 2006


I also wanted to point out that I had the exact same error message onmy linux machine running CentOS and ruby 1.84 + rails 1.1.x.
I won't have access to my computer (at work) till tuesday but is theresome environment setting  missing or something?
It's weird that I would have the exact same problem with both linux and windows.

On 4/13/06, Curt Hibbs <curt.hibbs at gmail.com> wrote:> On 4/13/06, David Morton <mortonda at dgrmm.net> wrote:> > -----BEGIN PGP SIGNED MESSAGE-----> > Hash: SHA1> >> > Tim Uckun wrote:> > > When attempting to do various things like cap or rake migrate I get> anuninitialized constant WEBrick error. Does anybody what could becausing> this?  A transcript is attached below.> > >> > > D:\Source\trunk\engine>lsengine           gems>    install_gems.rb> > > D:\Source\trunk\engine>cap --apply-to> engineD:/InstantRails/ruby/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:123:in> `const_missing': uninitialized constant WEBrick (NameError)        from> D:/InstantRails/ruby/lib/ruby/gems/1.8/gems/activesupport-> 1.3.1/lib/active_support/dependencies.rb:131:in> `const_missing'        from> ./engine/config/environment.rb:56        from> D:/InstantRails/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in> `require'        from> D:/InstantRails/ruby/lib/ruby/gems/1.8/gems/capistrano-> 1.1.0/lib/capistrano/generators/rails/loader.rb:5:in> `load!'        from> D:/InstantRails/ruby/lib/ruby/gems/1.8/gems/capistrano-1.1.0/lib/capistrano/cli.rb:252:in> `execute_apply_to!'        from> D:/InstantRails/ruby/lib/ruby/gems/1.8/gems/capistrano-> 1.1.0/lib/capistrano/cli.rb:223:in `execute!'        from> D:/InstantRails/ruby/lib/ruby/gems/1.8/gems/capistrano-1.1.0/lib/capistrano/cli.rb:12:in> `execute!'        from D:/InstantR> > ai!> > > ls/ruby/lib/ruby/gems/1.8/gems/capistrano-> 1.1.0/bin/cap:11        from D:/InstantRails/ruby/bin/cap:18> > > D:\Source\trunk\engine>> >> > I think you are running command outside of the usual instantrails> environment,> > So it may not be picking up the right path...   I think there are some> > environment variables that need to be set.> >> > Anyone else have more info on that? I'm dead tired right now...> >>> There was something similar that was a reported bug in Rails 1.1 (or 1.1.1)> but I believe that was a "redefined" contant error, not "uninitialized". Its> probably not related, but I mention it just in case. That particular problem> is fixed in Rails 1.1.2 (which is in Instant Rails 1.3).>>  Curt>>>>> _______________________________________________> Instantrails-users mailing list> Instantrails-users at rubyforge.org> http://rubyforge.org/mailman/listinfo/instantrails-users>>


More information about the Instantrails-users mailing list