[Instantrails-users] Typo 2.5.6 Installed on InstantRails

Juanma Cervera juanmacervera at gmail.com
Wed Oct 19 12:56:52 EDT 2005


E Gard wrote:
> Fixing the admin stylesheet routing issue.
>
> Two more steps for Typo 2.5.6 on InstantRails:
>
> 1) Copy the admin css stylesheet
>
> Copy administration.css
> from
> rails_apps\typo-2.5.6\public\stylesheets
> to
> rails_apps\typo-2.5.6\themes\azure\stylesheets
>
>
> 2) Edit the app's routes.rb
>
> Edit the rails_apps\typo-2.5.6\config\routes.rb file:
>
> After line 60 add
>
> # Added this route after line 60 in routes.rb
> map.connect 'stylesheets/:filename',
>   :controller => 'theme', :action => 'stylesheets'
>
> P.S.  I haven't had any AJAX problems with Typo.
> However, I only use it on a single box and
> do everything from the admin (add articles, etc.)
> If you have AJAX trouble, are you using a third party
> tool to manage you Typo site?
>
> There is one other change, but I'm not sure if it
> impacts anything:
>
> rails_apps\typo-2.5.6\public\.htaccess
> line 19 Changed dispatch.fcgi to dispatch.cgi
>
> ---------
> Ed
>
>
> 	
> 		
> __________________________________ 
> Yahoo! Mail - PC Magazine Editors' Choice 2005 
> http://mail.yahoo.com
> _______________________________________________
> Instantrails-users mailing list
> Instantrails-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/instantrails-users
>
>   
Hi,
Now it works perfectly, but ...
Why is the behavior different when it is using Webrick and when it is 
using SCGI?
Where is the problem?
The question is only for getting a better understanding. I am trying to 
learn ruby, rails, apache, etc.
Maybe too many things at the same time.
Thanks.

Juan M. Cervera


More information about the Instantrails-users mailing list