[Instantrails-users] Fwd: InstantRails - Apache won't start because of port conflicts

Will Shattuck willshattuck at gmail.com
Thu Nov 17 16:06:19 EST 2005


I got the same thing but it was because I changed only the Listen
directive and not the Port.  Make sure both are the same.  Also, check
to make sure the IIS for Windows XP/2000 is not running

* Right click My Computer
* Left click Manage
* Expand Services and Applications.  Check if Internet Information
Service is there.
* If it is then expand it. Expand Websites. Left click on Default Website
* Then Right click Default Websit and if STOP is available to click on
then IIS is running on the port InstantRails wants to use.

I have a help desk app running on my windows xp box and had the same
issues until i changed the port to both in the conf file.




On 11/17/05, Curt Hibbs <curt.hibbs at gmail.com> wrote:
> I'm posting this to the Instant Rails mailing list. Does anybody have clue
> what might be going on here?
>
>  Curt
>
> ---------- Forwarded message ----------
> From: Frank Hale <frankhale at gmail.com>
> Date: Nov 17, 2005 8:12 AM
> Subject: Re: InstantRails - Apache won't start because of port conflicts
> To: curt at hibbs.com
>
> Yeah I did that. I changed it to port 8080 since it says 80 is being
>  used which I know it isn't. I got the same issue. Apache will not
> start from InstantRails.
>
>
> On 11/17/05, Curt Hibbs <curt.hibbs at gmail.com> wrote:
> > On 11/17/05, Frank Hale < frankhale at gmail.com> wrote:
> > > Hello,
> > >
> > > I'm trying out InstantRails but apache will not start because it keeps
> > > saying something is using the web port. I've configured Apache to use
> > > a different port other than 80 and it still refuses to start Apache,
> > > same error. I tried doing a google search and looked at the FAQ but
> > > nothing comes up. The error is listed below, it's in my instantrails
> > > log file.
> > >
> > > 17/11 08:08:14 Apache : Apache cannot be runned : another Web server
> > > use the Web port
> > >
> > > If you have seen this and know how to resolve it I'd appreciate any
> > > info you can offer.
> > >
> >
> >  In the main Instant Rails main menu choose "Configure >> Apache". This
> will
> > bring up apache's httpd.conf file in notepad. Then search for and change
> the
> > port number specified in both the "Listen" and "Port" directives. That
> > should do it.
> >
> >  Curt
> >
>
>
> --
> "This life is built on match sticks and can crumble at anytime. I'm on
> the top floor and I sway in the opposite direction of the wind to
> counter act the force of gravity."
>
> _______________________________________________
> Instantrails-users mailing list
> Instantrails-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/instantrails-users
>
>
>


--
Will
--------
Will Shattuck  ( willshattuck.at.gmail.com )
Home Page:  http://www.thewholeclan.com/will
My Calligraphy:  http://www.thewholeclan.com/will/gallery3/calligraphy

When you get to your wit's end, you'll find God lives there.



More information about the Instantrails-users mailing list