[Instantrails-users] Upgrading Instant Rails to Rails 1.0 RC5 (aka 0.14.4)

Frank Hale frankhale at gmail.com
Fri Dec 9 23:20:29 EST 2005

Theoretically the same code should still work, right? I am a n00b with
Rails and have only developed a very basic login system that works on
a Linux machine with Rails 0.14.4 and MySQL 4.1.12. It only has one
table and one model with a method that calls find. When I try to run
the same code on Instant Rails using Webrick (that is my preferred
development server) it fails to run giving me a NoMethodError. When I
run on Linux it works as expected. If I comment out the find method in
my model then I don't get the error on Instant Rails but yet the code
cannot function properly without it.

On 12/9/05, Curt Hibbs <curt.hibbs at gmail.com> wrote:
> On 12/9/05, Frank Hale <frankhale at gmail.com> wrote:
> > I went to my linux box, upgraded to 0.14.4 and everything was still
> > working fine. I can't get the same code to work with Instant Rails, my
> > guess is because of the fact that there is no Ruby-MySQL C binding.
> > That is the only difference between both setups. I use only Rails +
> > MySQL and Webrick. Such is life I suppose.
> >
> Hmmm... is any one else having this problem? If so, its looks like I'll have
> to get the C bindings into Instant Rails (it was on the todo list anyway,
> just not at the top).
> Curt

"This life is built on match sticks and can crumble at anytime. I'm on
the top floor and I sway in the opposite direction of the wind to
counter act the force of gravity."

More information about the Instantrails-users mailing list