[Instantrails-users] Upgrading Instant Rails to Rails 1.0 RC5 (aka 0.14.4)

Frank Hale frankhale at gmail.com
Fri Dec 9 22:40:19 EST 2005


I went to my linux box, upgraded to 0.14.4 and everything was still
working fine. I can't get the same code to work with Instant Rails, my
guess is because of the fact that there is no Ruby-MySQL C binding.
That is the only difference between both setups. I use only Rails +
MySQL and Webrick. Such is life I suppose.

On 12/9/05, Frank Hale <frankhale at gmail.com> wrote:
> That's what google says. I reinstalled Instant Rails, updated and
> don't seem to be getting that error anymore. What I get now is a
> NoMethodError when I try to call the find function from within my
> model. I have a simple test app with just one call to 'find' in my
> model for a simple table that stores a username and a hashed password.
> This all works fine on Linux / Rails 0.14.3 but refuses to work on
> Instant Rails either 0.14.3 or 0.14.4. I'm using only Webrick to test.
> I'm not using Apache / SCGI because they are overkill for me.
>
> On 12/9/05, Curt Hibbs <curt.hibbs at gmail.com> wrote:
> > The pure Ruby bindings are included with Rails, but the C based bindings are
> > not. Obviously the Ruby bindings are there or you would not have gotten a
> > connection to lose.
> >
> > Are you saying that the answers you found indicated that installing the C
> > based bindings would solve this problem?
> >
> > Curt
> >
> > On 12/9/05, Frank Hale <frankhale at gmail.com> wrote:
> > > Ok, after updating I was having some weird problems with Instant
> > > Rails. Now I'm now getting the following error:
> > >
> > > Lost connection to MySQL server during query
> > >
> > > After googling seems every answer to this problem is the fact that the
> > > MySQL Ruby bindings are not installed. Is there a Win32 port of them
> > > somewhere?
> > >
> > > On 12/9/05, Frank Hale <frankhale at gmail.com> wrote:
> > > > Anyone having any trouble with the update? I have a model that uses
> > > > the find method and it refuses to return any data now. It doesn't
> > > > error out, I just don't get what I expect to get. Worked fine on Linux
> > > > with Rails 0.14.3 but does not work on Instant Rails with 0.14.4
> > > >
> > >
> > > _______________________________________________
> > > Instantrails-users mailing list
> > > Instantrails-users at rubyforge.org
> > > http://rubyforge.org/mailman/listinfo/instantrails-users
> > >
> >
> >
> > _______________________________________________
> > Instantrails-users mailing list
> > Instantrails-users at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/instantrails-users
> >
> >
> >
>
>
> --
> "This life is built on match sticks and can crumble at anytime. I'm on
> the top floor and I sway in the opposite direction of the wind to
> counter act the force of gravity."
>


--
"This life is built on match sticks and can crumble at anytime. I'm on
the top floor and I sway in the opposite direction of the wind to
counter act the force of gravity."



More information about the Instantrails-users mailing list