[Instantrails-users] installing typo: something got easier.

David Morton mortonda at dgrmm.net
Wed Dec 7 23:38:51 EST 2005

Hash: SHA1

I am at a loss for words;  I spent a lot of time figuring out the right hacks to
do this a couple of weeks ago.  Now, it appears that no hacks are needed.

I downloaded a fresh InstantRails preview 5, and a fresh typo 2.6.0

Here's my virtualhost entry:

<VirtualHost *>
    ServerName typo
    # handle all requests through SCGI
    SCGIMount /scgi-bin/
    DocumentRoot C:/INSTAN~2/rails_apps/typo-2.6.0/public
    <Directory C:/INSTAN~2/rails_apps/typo-2.6.0/public>
        Options +FollowSymLinks
        Order allow,deny
        allow from all
    AddDefaultCharset utf-8
    ErrorDocument 500 /500.html
    ErrorDocument 404 /404.html

I rewrote one line in the .htaccess:

RewriteRule ^(.*)$ /scgi-bin/%{REQUEST_URI} [QSA,L]

I installed the database schemas, set my hosts file...

And it all works perfectly.  No adding a plugin.  No editing routes.  Caching
works perfectly.  There appears to be no problem to fix.  Why did we spend so
much time fixing things with that plugin that Trevor wrote... when I can't even
duplicate it now.  Did it get installed into preview 5 somehow?

- --
David Morton
Maia Mailguard                        - http://www.maiamailguard.com
Morton Software Design and Consulting - http://www.dgrmm.net
Version: GnuPG v1.4.2 (MingW32)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org


More information about the Instantrails-users mailing list