[gettext-u-en] Problems with rails sample in gettext-1.1.1

Jan Schreiber jan.schreiber at gmail.com
Thu Feb 9 15:07:26 EST 2006


Hi!

I have some problems running the gettext-1.1.1 rails sample.

My rails version is 1.0.0 and I'm using Ruby 1.8.3.

#> rake updatepo
(in /usr/lib/ruby/gems/1.8/gems/gettext-1.1.1/samples/rails)
numeric literal without digits
rake aborted!
exit
/usr/lib/ruby/gems/1.8/gems/gettext-1.1.1/samples/rails/Rakefile:216
(See full trace by running task with --trace)
jans at dina:/usr/lib/ruby/gems/1.8/gems/gettext-1.1.1/samples/rails$
sudo rake --trace updatepo
(in /usr/lib/ruby/gems/1.8/gems/gettext-1.1.1/samples/rails)
** Invoke updatepo (first_time)
** Execute updatepo
numeric literal without digits
rake aborted!
exit
/usr/lib/ruby/gems/1.8/gems/gettext-1.1.1/lib/gettext/rgettext.rb:117:in `exit'
/usr/lib/ruby/gems/1.8/gems/gettext-1.1.1/lib/gettext/rgettext.rb:117:in `parse'
/usr/lib/ruby/gems/1.8/gems/gettext-1.1.1/lib/gettext/rgettext.rb:107:in `each'
/usr/lib/ruby/gems/1.8/gems/gettext-1.1.1/lib/gettext/rgettext.rb:107:in `parse'
/usr/lib/ruby/gems/1.8/gems/gettext-1.1.1/lib/gettext/rgettext.rb:172:in `run'
/usr/lib/ruby/gems/1.8/gems/gettext-1.1.1/lib/gettext/rgettext.rb:170:in `open'
/usr/lib/ruby/gems/1.8/gems/gettext-1.1.1/lib/gettext/rgettext.rb:170:in `run'
/usr/lib/ruby/gems/1.8/gems/gettext-1.1.1/lib/gettext/rgettext.rb:184:in
`rgettext'
/usr/lib/ruby/gems/1.8/gems/gettext-1.1.1/lib/gettext/utils.rb:47:in
`update_pofiles'
/usr/lib/ruby/gems/1.8/gems/gettext-1.1.1/samples/rails/Rakefile:216
/usr/lib/ruby/gems/1.8/gems/gettext-1.1.1/samples/rails/Rakefile:215:in `call'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:232:in `execute'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:232:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:232:in `execute'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:202:in `invoke'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:195:in `synchronize'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:195:in `invoke'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:1719:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:1719:in `each'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:1719:in `run'
/usr/lib/ruby/gems/1.8/gems/rake-0.7.0/bin/rake:7
/usr/bin/rake:18


Any ideas what the problem might be?

Also, I get the same error message when I run 'rake updatepo' on
another rails application that I have created. The parser seems to
crash when a '0' occurs in e.g. a controller.

def test
  quux = _('test')
  foobar = 0
end

will crash while

def test
  quux = _('test')
  foobar = 1 -1
end

does not crash.

I'm running rails on Ubuntu Breezy.

Can you help me out?

Regards,
Jan



More information about the gettext-users-en mailing list