[fxruby-users] Gem Install Fxruby

Lars Kanis lars at greiz-reinsdorf.de
Fri Jun 28 18:46:10 UTC 2013


Am 28.06.2013 19:39, schrieb Marco Kittel:
> dialogs_wrap.cpp:583:41: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
OK, that makes sense. Ubuntu obviously uses a ruby version compiled with
the gcc option -Werror=format-security. That is generally a good thing,
but breaks the fxruby build. Unfortunately the code in question is
generated by swig, so I can not fix it immediately.

As a work-a-round you might remove all occurrences of
"-Werror=format-security" from
/usr/lib/ruby/1.9.1/x86_64-linux/rbconfig.rb before install.

If you're lucky, you might open an issue on github. Otherwise I'll do so.

Regards,
Lars

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/fxruby-users/attachments/20130628/18b0cd98/attachment-0001.html>


More information about the fxruby-users mailing list