[fxruby-users] Gem Install Fxruby

Andreas Schmidt watobo at siberas.de
Mon Jul 1 07:04:03 UTC 2013


Hi Marco,

on Linux I use (FX)Ruby only via RVM because I also experienced lots of
build errors with the default installation/packages.

I've written a installer script for BackTrack5 (based on ubuntu) for my
FXRuby project:
http://siberas.blogspot.de/2012/06/installing-watobo-on-backtrack-5r2.html

regards,

-andy


 Am 28.06.2013 19:39, schrieb Marco Kittel:
> sudo apt-get install g++ libxrandr-dev libfox-1.6-dev
> [sudo] password for marco: 
> Paketlisten werden gelesen... Fertig
> Abhängigkeitsbaum wird aufgebaut.       
> Statusinformationen werden eingelesen.... Fertig
> g++ ist schon die neueste Version.
> libfox-1.6-dev ist schon die neueste Version.
> libxrandr-dev ist schon die neueste Version.
> 0 aktualisiert, 0 neu installiert, 0 zu entfernen und 0 nicht aktualisiert.
> 
> it is everything installed.
> 
> 
>  sudo gem install fxruby
> Building native extensions.  This could take a while...
> ERROR:  Error installing fxruby:
>     ERROR: Failed to build gem native extension.
> 
>         /usr/bin/ruby1.9.1 extconf.rb
> checking for sys/time.h... yes
> checking for signal.h... yes
> checking for deflate() in -lz... yes
> checking for png_create_read_struct() in -lpng... yes
> checking for jpeg_mem_init() in -ljpeg... yes
> checking for TIFFSetErrorHandler() in -ltiff... yes
> checking for XftInit() in -lXft... yes
> checking for XShmQueryVersion() in -lXext... yes
> checking for XFindContext() in -lX11... yes
> checking for glXCreateContext() in -lGL... yes
> checking for gluNewQuadric() in -lGLU... yes
> creating Makefile
> 
> make
> compiling librb.c
> librb.c: In Funktion »SWIG_Ruby_define_class«:
> librb.c:487:11: Warnung: Variable »klass« gesetzt, aber nicht verwendet [-Wunused-but-set-variable]
> compiling dialogs_wrap.cpp
> dialogs_wrap.cpp: In Funktion »void SWIG_exception_(int, const char*)«:
> dialogs_wrap.cpp:583:41: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp:586:38: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp:589:43: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp:592:41: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp:595:40: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp:598:43: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp:601:41: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp:604:42: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp:607:39: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp:610:36: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp:613:43: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp: In Funktion »VALUE _wrap_FXMessageBox_error__SWIG_0(int, VALUE*, VALUE)«:
> dialogs_wrap.cpp:4558:89: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp: In Funktion »VALUE _wrap_FXMessageBox_error__SWIG_1(int, VALUE*, VALUE)«:
> dialogs_wrap.cpp:4565:89: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp: In Funktion »VALUE _wrap_FXMessageBox_warning__SWIG_0(int, VALUE*, VALUE)«:
> dialogs_wrap.cpp:4584:91: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp: In Funktion »VALUE _wrap_FXMessageBox_warning__SWIG_1(int, VALUE*, VALUE)«:
> dialogs_wrap.cpp:4591:91: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp: In Funktion »VALUE _wrap_FXMessageBox_question__SWIG_0(int, VALUE*, VALUE)«:
> dialogs_wrap.cpp:4610:92: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp: In Funktion »VALUE _wrap_FXMessageBox_question__SWIG_1(int, VALUE*, VALUE)«:
> dialogs_wrap.cpp:4617:92: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp: In Funktion »VALUE _wrap_FXMessageBox_information__SWIG_0(int, VALUE*, VALUE)«:
> dialogs_wrap.cpp:4636:95: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp: In Funktion »VALUE _wrap_FXMessageBox_information__SWIG_1(int, VALUE*, VALUE)«:
> dialogs_wrap.cpp:4643:95: Fehler: Format ist kein Zeichenkettenliteral, und keine Formatargumente [-Werror=format-security]
> dialogs_wrap.cpp: Im globalen Gültigkeitsbereich:
> dialogs_wrap.cpp:558:13: Warnung: »void SWIG_AsVal(VALUE, int*)« definiert, aber nicht verwendet [-Wunused-function]
> In file included from ./include/FXRuby.h:878:0,
>                  from ./include/FXRbCommon.h:99,
>                  from dialogs_wrap.cpp:564:
> ./include/inlinestubs.h:20:1: Warnung: »void FXApp_init(FX::FXApp*, VALUE, bool)« definiert, aber nicht verwendet [-Wunused-function]
> dialogs_wrap.cpp:1101:1: Warnung: »void free_FXDialogBox(FX::FXDialogBox*)« definiert, aber nicht verwendet [-Wunused-function]
> dialogs_wrap.cpp:1426:1: Warnung: »void free_FXDirDialog(FX::FXDirDialog*)« definiert, aber nicht verwendet [-Wunused-function]
> dialogs_wrap.cpp:1905:1: Warnung: »void free_FXFileDialog(FX::FXFileDialog*)« definiert, aber nicht verwendet [-Wunused-function]
> dialogs_wrap.cpp:2169:1: Warnung: »void free_FXColorDialog(FX::FXColorDialog*)« definiert, aber nicht verwendet [-Wunused-function]
> dialogs_wrap.cpp:2414:1: Warnung: »void free_FXFontDialog(FX::FXFontDialog*)« definiert, aber nicht verwendet [-Wunused-function]
> dialogs_wrap.cpp:2752:1: Warnung: »void free_FXReplaceDialog(FX::FXReplaceDialog*)« definiert, aber nicht verwendet [-Wunused-function]
> dialogs_wrap.cpp:2999:1: Warnung: »void free_FXSearchDialog(FX::FXSearchDialog*)« definiert, aber nicht verwendet [-Wunused-function]
> dialogs_wrap.cpp:3913:1: Warnung: »void free_FXPrintDialog(FX::FXPrintDialog*)« definiert, aber nicht verwendet [-Wunused-function]
> dialogs_wrap.cpp:4249:1: Warnung: »void free_FXProgressDialog(FX::FXProgressDialog*)« definiert, aber nicht verwendet [-Wunused-function]
> dialogs_wrap.cpp:4658:1: Warnung: »void free_FXMessageBox(FX::FXMessageBox*)« definiert, aber nicht verwendet [-Wunused-function]
> dialogs_wrap.cpp:5066:1: Warnung: »void free_FXWizard(FX::FXWizard*)« definiert, aber nicht verwendet [-Wunused-function]
> dialogs_wrap.cpp:5414:1: Warnung: »void free_FXChoiceBox(FX::FXChoiceBox*)« definiert, aber nicht verwendet [-Wunused-function]
> cc1plus: Einige Warnungen werden als Fehler behandelt
> make: *** [dialogs_wrap.o] Fehler 1
> 
> 
> Gem files will remain installed in /var/lib/gems/1.9.1/gems/fxruby-1.6.27 for inspection.
> Results logged to /var/lib/gems/1.9.1/gems/fxruby-1.6.27/ext/fox16_c/gem_make.out
> 
> that's all i get.
> 
> regards
> 
> Marco
> 
> 
> 
> _______________________________________________
> fxruby-users mailing list
> fxruby-users at rubyforge.org
> http://rubyforge.org/mailman/listinfo/fxruby-users
> 



More information about the fxruby-users mailing list